How to report bugs together with the Wappler debug log

Updated for Wappler Version 1.1.0 and higher

We have a built-in bug reporting in Wappler that auto post a topic in this forum together with the debug log.
Starting from version 1.1.0 the logging isn’t available per default, so you need to restart Wappler with logging.
You can do that by clicking on the Wappler’s tray icon (Windows right click) and then choose “Restart with Logging”

Then reproduce your problem and choose to submit a bug report from the Wappler menu File / Submit error report … ot Alt+ctrl+p (or alt+cmd+p for mac)

The debug log will be then zipped togger with a screenshot from your current Wappler view.
The folder with the zipped problem report will be opened in Windows Explorer for Windows or Finder for Mac.

At the same time a draft forum topic post will be opened in your browser so you can describe your problem.
Drag the zipped problem report file to the topic post as well that has being generated for you and post the topic.

Please be as descriptive as possible in the steps to reproduce your problem. It will help us a lot to quickly solve it. If possible also include a short video that shows exactly the steps you took and the problem.

Manual procedure

In case the above procedure do now work somehow, here are instructions of where you can locate the debug log your slef so you can post it to the forum manually.

  • for Windows it is located at:
    C:\Users\username\AppData\Local\Wappler\User Data\chrome_debug.log
    (make sure hidden files are visible in Windows Explorer)

  • for Mac it is under:
    /Users/username/Library/Application Support/Wappler/chrome_debug.log
    or shorter: ~/Library/Application Support/Wappler/chrome_debug.log
    (You can choose in Finder / Go To Folder ~/Library/Application Support/Wappler first)

So when you find this log file, zip it and post it in the bug topic in this forum that describes your problem. Make sure you get the file right after the problem was occurred.

Also try to be as detailed as possible when posting a bug report, so we can easily reproduce the problem.
Always post the bug reports in the Wappler General Bugs category

That will help us a lot in investigation your problem - and make Wappler a rock solid product!

Thanks a lot!

3 Likes
Flow data picker errors when using SSI
ODBC system connection
Wappler won't startup on Mac - too old OSX
Visual bug with code view in data binding
Bug Report #1648652536642
Bug Report #1648652145646
Specific Postgres table schema not refreshing
Drag window in macOS not working v2
Bug Report #1643918139140
Wappler Freezes after update
Conditions missing in Server Connect Database Query Builder
App structure panel / properties panel / codeview not in sync
If File Exists make Data Bindings structure innaccesible
Bug Report #1639401572050
Tray icon for automatic install not active!
Cannot Save at all after an edit
Routes panel empty and no edits display in the routes file
Linux: Bootstrap 5 / NodeJS / Form/Table Generator Black
Knex: Required configuration option 'client' is missing
Workflows - Globals - add database query, cant open query editor
Switch between Projects not working
Unable to add/remove stripe event action to its folder
App Structure is not opening, it only shows loading - using windows 8
Bug Report from PaulBS #2021-7-25_15-11-13
Tab editor shows up 2 times
Form generator not populating fields
Beta 11 : can't close some tabs
Cannot edit queries when based on several Postgres Schema
Error when saving API Query to production server with 3.9.8
Blank design view and freezing before + Err Connection refused
Wappler crashes
Can't save API file with dynamic connections
Cant save server action
Remote Development table not accessible in db manager
Inifinte loading loop when opening database manager - can't set up a DB
Problem saving files
Problem refreshing database schema
ServerConnect Input Params not shown
Data picker is not working in SC again for API Action
Cannot save database connection
MySQL 5.6: Problem fetching database table columns - takes long time
MSSQL Re-edit of Query & Paged Query with View does not work
Postgres - No columns info avaiable
Seeds and changes missing for Postgres in 3.7.6
DB Error when trying to Get Schema / Update Changes (Production DB, MySql8, AWS)
Problems creating a database connection under globals
Ctrl+s on code view randomly deletes all content of the page
New Library Action does not show the steps
Problems with NodeJS in Database Manager
Database connection (Microsoft SQL Server) not saving
Direct Database Connection through SSH tunnel
Database action changes not saved from UI
Traefik without Portainer does not work
Mobile: New database connection not saving
Apply docker machine services fails to perform
Problems with saving api action
Documents refuse to save
Date Formatting Not Working
MacBook Pro with BigSur Non Responsive and Fan Running
It is impossible to save linked DB actions after upgrade to Wappler 3.6.0
Database manager issues
Wappler crashes when try to submit Error report
Database Loading
Git Manager not loading
Server connect ERROR
Query data not appearing in App Structure > Data Bindings
Bug Report from cynthiacorley #2020-10-10_14-52-58
Added new database connection but database manager just says "Loading"
Problems with custom queries
Problem running Custom Query in SC
Action Picker Not Working on API Action Options
Wappler won't startup?
Inserting the Data Store component
Cannot select dynamic data in server API connector UI
Node project creating a partial after the first one doesn't seem to work?
3.3.0 mac osx issues for mobile project
No local git repository for one of our projects
Server Connect Not Populating Data Using NodeJS
System Hangs on Postgres connection
Trouble with database manager
Wappler terminal crashed
Database Insert UI Save Issue
Wappler freezes regularly on macOS
Server action - Picker just displays loading message
Table Join options disappear
Button has no properties
Little bug when save file
Bug in Database Column Update Step
No steps displayed in Server Connect
Wappler won't load
DOM element property panel not appearing
Data store Insert Record no longer shows properties
Add Server Connect Component - Configuration Not Possible
Project settings ftp test connection
Server API Connector - Inspector UI rendering problems
Problems after renaming database table or columns
Can't open query builder
Blank page after loading template a second time
Wappler issues
Refresh database from within Database Insert/Update is not showing-up newly added database field
Transfering data from a table to another database
Wappler quits when pulling from Github after first opening it
Bindings don't always bind
Bug in Validation
Can not edit code in split or code view
Problems adding components in App structure
Cannot insert server side include
File opening with no content appearing
Can't add security enforcer 2.3.5/Experimental Mode
Can't add security enforcer 2.3.5/Experimental Mode
Not all database fields are listed
Code view becomes read only
Experimental Code Editor occasionally locked
Route Save Error
Route Save Error
Typing ">" freezes Wappler beyond recovery
Linux: No Design Panel Options
Linux: Empty Design Panel
Form "DATA" doesnt shown in binding panel
Data Binding stopped working after Array component added to page
Corrupted database connection file
Connecting to AWS EC2 with ssh key
Htaccess not copied to target
Issue with Server Connect not selectable in the data picker
Data base connection error - 414 Request-URI Too long
Minor bug: Refresh database schema in Database Update
Server action not saving
Data Bindings loading infinity
Crashing wappler 2.2.2 on unavailable network drives
Wappler freezes anytime i bind data
Possible bug with Wappler 2.2.1 Git push
File problems when using Windows Share for the Wappler Project
Bug Report from transcoderm #2019-7-5_12-23-46
Bug: DAta Bindings Panel blank for popovers
Reporting errors with debug log
Files lost after Wappler crash
Program hangs when you try to open files
Can't Save File
Test connection not working
Styles panel doesn't refresh
Can't see new Design Panel
Wappler is crashing all the time when I use file manager
Query from WordPress
Files Not Saving
Problem with Styles panel
Renaming of action file not working anymore
Wappler freezes on the Mac sometimes
Switching projects loading problem
Buggy Undo/Code & Design Sync
Switching projects problem
HTML Mailer - text content is not saving when adding only dynamic binding
Wappler and files in the server
SQL connection to Microsoft SQL Server on Windows
Dynamic Table Repeat Children usage troubles
When using an ALIAS to join two tables, query is not saved and has issues displaying the ALIAS values
Bug Report from wld #2018-11-15_12-7-21
Project settings save button problem
Mac: Wappler crashes when saving the file
Mac OS: dimmed app when preview
Local Publishing Issues
Issues on Mac since last update
Classic ASP: Server Connect Action Steps Disappear
Selected elements in Design View, on remote sites, no longer highlighted
Style Panel is lost after updating
AllIncludes in not defined error
Bug Report from randyrie #2018-6-13_10-2-1
The Editor's Frequent Freeze - on code edits
Framework 7.2 Wappler Crash
Google Maps usage
Connecting to AW EC2 instances using ssh
Code/Design view synchronization issues in v1.0.5
Error when saving pages and won't save
Corrupted page contents
Indiegogo backers license activation
Cannot Subscribe to Pro version?
Can't subscribe
Styles Panel not functioning as expected
Gitlab Credential Error
Error refreshing schema database "cannot read property 'refs' of undefined"
Creating Remote Docker Target - will not save
4.8.0 DB Manager Error on Schema Refresh

A post was split to a new topic: Wappler Crash on Save