V4.9.0 -NodeJS - ReferenceError: Hash is not defined

Wappler Version : v4.9.0
Operating System : MacOS
Server Model: NodeJS
Database Type: MSSQL
Hosting Type: Docker

I have started getting ReferenceError: Hash is not defined - dmxAppConnect.js:7 error in the dev console after upgrading to v4.9.0. The error is happening on all pages regardless of whether there’s a server connect call or not.

From the testing so far, the data is loading correctly. I don’t know yet if there are issues with some server calls not working correctly.

Here an update: dmxAppConnect.zip (26.4 KB)


It’s working, no errors in the dev console. I also noticed during my further testing that some of the server connects were failing, but these are working correctly now as well.

Many thanks @patrick for promptly attending to this issue and providing an updated file :slight_smile:

In case it helps, I also saw this issue, but only in some specific cases.
The update fixed it so :+1:

I have the same error with this configuration:
Wappler Version : v4.9.0
Operating System : Windows 10
Server Model: PHP
Database Type: MySQL

i tried to replace the AppConnect file with that @patrick sent but he doesn’t work.
This is the error:

I was getting an error in the dmxAppConnect.js file. The error shown in your screenshot is from the BaseComponent.js file. Not sure whether this error is for the same bug or a different issue.

This fixed my issue with longer tables not displaying! :grin: :grin:

This has been fixed in Wappler 4.9.1

This topic was automatically closed after 2 days. New replies are no longer allowed.