Docker Machine DB Error - Access denied...(using password: YES)

Previously reviewed posts with similar use cases:

With the closest being: Docker Setup - Access Denied for Database User

  • Relating factor being Docker Machine & the error
  • NOTE: Had made a test project maybe 2 weeks ago with Docker Machine and a local MySQL DB and it worked fine…even opened it up today while testing this problem that occurred with a brand new project and the older project’s Database WAS working today at A point and then stopped i think after updating/publishing…
    Throughout my troubleshooting and frustration I ended up deleting that project and any other docker desktop data to start fresh along with the wappler project…
    Before deleting I did compared the DB settings within the .Wappler dir & there were no notable differences
  • Stuck at this point…

======== TEMPLATE BUG FORM ========

Wappler Version : v3.8.1
Operating System : Windows 10:19042.804
Server Model: NodeJS
Database Type: MySQL
Hosting Type: Docker

Expected behavior

Make a new local dev nodeJS project - Configure the local target to add the MySQL DB, enable and leave everything default - save - be able to see the DB on the left panel

Actual behavior


  • Below was the Original error received when I was attempting to view the DB on the project that I deleted and the reason for searching (using password: YES) but when starting from scratch the above error persists


How to reproduce

  • Brand new project: HOST-SERVER
  • Services Launch: HOST-SERVICES
  • Enable DB & leave as default:
  • Services Launch: HOST-SERVICES2
  • Verify Docker Desktop: HOST-DOCKER-DESKTOP

Any guidance or suggestions are greatly appreciated!

I will try this as soon as I can to see if I can reproduce. But while I’m not at the computer just wondering can you use MariaDB instead to get you going if it’s stoping you from working on a project?

1 Like

Just tested on a new project with MariaDB and the results are exactly the same
Appreciate you helping look into this - please let me know of anymore testing or data I can provide

Please do not edit the database connection generated with docker manually!

We already prohibit that in the latest version but seems even more enforcement in server connect is needed.

Just edit your projects settings and re- save them to generate the correct database settings

Thanks for the response!
I did not change the generated DB connection in docker just compared*
Started from scratch - generated a new project, turning on DB and saving it…

It just takes a minute for the database to start up, just go to the connection in the db manager and hit refresh (f5) later on.

1 Like

I can confirm same thing happens for me. What worked for me @canickyp was after a little time right clicking the DB icon and clicking Refresh Schema

1 Like

I got the same both on local docker than remote docker. Just click deploy again and after refresh … working welk

1 Like

Thanks everyone! That worked! In the past I was going too fast…
On MariaDB - after deploying I watched the db container logs and saw it creating the user and the demo data a minute or two after deployment.
For SQL - it took muuch longer about 4+ minutes…

Solution: Take more time

Is this a performance issue with my local machine or more of a build speed limitation with docker?

Regardless glad to get it working and to better understand how it works

1 Like

Hmm that is too long indeed. What OS are you on? And did you start with clean database or was it a backup that you are restoring?

1 Like

I am on Windows 10 Pro 20H2 Build 19042.804
Using a Lenovo ThinkCentre AMD Ryzen 5 PRO 2400GE w/ Radeon Vega Graphics 3.20 GHz & 24 GB RAM - not the beefiest system but also not “lacking” IMO

They are brand new projects no DB data besides testing with the demo data

3 days ago I wrote “just deply and refresh again”… and was working…
since today no more working :frowning:

How long are you waiting? I had to wait quite a while so try and be patient… don’t worry it was hard for me too! lol
You can open the docker desktop app and look at the logs of the DB container while its booting

I waited. I made new droplet. same problem.
delete the droplet. do new one… make new website as test and get same error !

I was doing the same thing …try making a new project updating it and enabling DB and walking away for 5-10 min then try again…

Also make sure you can connect to the local DB before pushing to the DO droplet

Local DB works perfectly… that’s the strange… :frowning:

EDIT: Now I start new site and seems to works at first.

Ohh okay - you will have to share more specific steps then

are you populating local data and saving the database and structure?

Yes. More, I added too a db connection to an external db. and still working

EDIT: I close everything. I made a new folder and selected blank new site on wappler.
I suppose that when you start to change things in the Targets projects settings… something happens.

Now will make little of experiments.

1 Like

These connection errors seem to be a bug with multiple causes perhaps. I have been seeing this on and off and the only thing which worked for me was to delete the project altogether and remake one in a brand new directory. Weirdly, I was also unable to redeploy the new project to the old folder after clearing it out (getting ‘folder not empty’ error).

Is there a way to uninstall wappler and all the related settings files and start again?