Access denied for local WAMP MySQL server

Upon trying to add the database connection I get the error :

SQLSTATE[HY000] [1044] Access denied for user "@‘localhost’ to database ‘mynewlocaltest’

Have you put in a username and password in the database connection. It looks as though your username is blank

No, I still can’t seem to figure out what I did wrong lol.

At least in the video, you didn’t include username

Im an idiot. Despite checking for it, i still didn’t do it. However, now I have a new error:
SQLSTATE[HY000} [1045] Access denied for user ‘mynewlocaltest’@‘localhost’ (using password: YES)

Your database is not using the default port of 3306, it is using 3308…enter that in the Wappler port field of the db connection action.

I am still receiving the same error :sleepy:

You have localhost for the target in Wappler…is the mysql server on the same computer as Wappler?


I’m running out of ideas :slight_smile: On the mysql side, try granting permission to locahost rather than Any Host.

How do I go about doing that?

I don’t use phpmyadmin…have a google of it.

How did you set up the username and password you are trying to use?

If you want to get started you can just use the root username with no password as that’s the default. But not recommended for production

Do you actually have a user name myweblocalhost set up with the proper permissions in PHPMyAdmin?

Something tells me you are using a wrong username and password or don’t have the permissions set right for that user. Can you provide a screenshot of your user accounts as I have shown?

Hey, it worked!!!