DB connection error: "Access denied for user..."

Having difficulty establishing my DB connection. I had been having issues so I deleted the entire project, database, and user(s) and started completely over. I’m now getting the following error:

Error using this Database Connection!
Server Response: SQLSTATE[28000] [1045] Access denied for user ‘robDB’@‘ip-***-*--***.ip.secureserver.net’ (using password: YES)

My FTP target is working fine. I know my credentials are correct. Is this something that can be solved with the host?


Hi Rob,

Database servers are usually restricted by remote IP address as well as username password credentials so maybe that is blocking you. And also make sure the user you created was granted access to the db you are connecting to.


Thanks, Ken.

The user is definitely granted access. Stumped for the time being.

SOLVED: I thought I’d post this in case some future user has the same problem. The problem was due to my DB password including special characters. I had used > < and : within the password. I’m not sure which of these are the offending character(s), but removing them the DB password and going with just alpha-numeric characters instantly solved the issue.


Good to hear that you solved it, but it is a bug when Wappler doesn’t handle the special characters in password correctly. We will investigate it.

1 Like