Server connect data unavailable in picker when nested conditionals

I’ve got to say that the server dtata bindings ui in action steps is still horrible buggy. inside repeats with conditions (multiple steps), none of the data can be accessed. Theses are so old bugs and now really need to be fixed. It’s so frustrating that this is still not working …

I’ve got a repeat region where I grab image size data then I make an upload, add a condition for if the upload is happening and that I try to add another condition where I load the uploaded image and try to check the images sizes. I can’t select the uploaded image as it does not appear in the ui.

Edit: I also can’t access the in the DatabseUpdate ui. Looks like repeats containing conditions aren’t supported (anymore).

Also accessing $parent data is NOT working in any steps/levels we’ve tried to apply.


Stil not fixed … how shall I build complex websites when conditions are not implemented correctly? I thought that the focus will be more set on fixing these kind of problems than on implementing new features?

1 Like

@George is there a way to dump into a json object or similar everything that the SC file has access to? Similar to the dmx object in browser but for the backend.

It would probably help people when the UI gets in the middle.


yes just execute the server action in the browser and check its output.

That would output what you select to output, but it wouldn’t output everything that SC action has access or visibility depending on the context.

I know it is not as easy as in App Connect but it would just be nice to be able to see all the variables a SC has access to in a big json structure.

That way it would be easy to identify when to use parent or parent.parent, etc.

I just see a recurring issue with people not knowing how to access certain variables from within repeats and depending on the context from the UI. But then getting the code to access it.

This is very easy to identify in AC by just exploring the dmx object, but not as easy in SC.

In server connect the data is flat and not structured like in app connect. The only action that creates an sub scope is the repeater. In the sample from @swf the image3 variable should be available in the scope, there is no sub scope generated by a condition and $parent is not needed (will not work).

I checked nested conditions and did not have problems selecting variables with the UI from within the nested conditions.

1 Like

$parent is also working really badly. the ui adds it but it doesn’t work. For example when I have a mailer and want to bind a database field from a parent repeat, the UI add $parent.$parent.EMail but this doesn’t work only when I manually remove the two $parents.

In my example: From the 4 uploads only the first is shown. So I can’t select any of the other in order to bind it to an update for example. All I see is this:

Repeats with conditions aren’t working properly for months now. I mentioned that many times but it hasn’t been fixed. I don’t need new features at the moment but the core of Wappler working. George you promised to fix these things after the summer break before releasing new feeatures, but I see that you again set the priority to releasing new features instead.

And here is the $parent problem I have. I want to add a database field from a single query into the send mail name, but I can’t select any to the query fields:

If I select the sqry it adds $parent.$parent.sqryGetWebsiteInfo. I’ve manually got to add sqryGetWebsiteInfo.Owner

The $parent is indeed not needed, perhaps @George can take a look at it.

Just to confirm your problem is just with the data pickers inside the server connect action?

Client side with the data pickers it is all ok in the app connect data pickers? As this was your previous problem with server actions having conditional steps.

So far it’s with the data pickers inside the server connect action.

In the app connect I encountered a different problem, where newly added repeats (in the server connect) are not shown in App connect data picker. I have to close the server connect and reopen it and sometimes also to php page itself to get access to the repeat. I think there is a refresh/caching problem in the macOS version.

Server connect data pickers are also not allowing you to select $value etc when in a repeat that is a split string.

1 Like

Have been experiencing these issues with pickers in both client and server side.
Have mostly just ignored the issue since I first encountered them, as I mostly tend to just write the code. The picker does not support ternary operator in complex conditions, which is used very frequently in projects I work on… So manual coding.

I don’t have any exact situation to report right now, but as @swf has posted, repeat is one of the places in server action where the pickers fails.
Also, in both server and client, when there is too many layers of nesting the picker breaks. Its either empty or elements are missing.

P.S. Since we are on topic of pickers, can the search be made faster? In my pages with 100s of elements, I sometimes have to wait for 30-60 seconds or more to get the results.

1 Like

Can you guys keep different issues and questions in separate topics, please?
When everyone reports a different issue in this topic we can’t really keep track of what’s initially reported.

1 Like

Still not fixed … :slightly_frowning_face:

As much as I appreciate the effort going in to new features, I have to agree that some of the core, especially data pickers (both client-side and server-side), could do with some love.

As this topic is about server-side
I ran into an issue with CSV import where the data pickers weren’t helping as they don’t take into account the position in the heirarchy:

This issue was assigned to @patrick and then unassigned because I posted a workaround, not a fix.

There have also been situations where I have nested conditionals/loops and trying to access any data in the picker is either impossible (not shown) or provides incorrect references (without $parent/$this etc.)

1 Like

I’m stuck with my work as I can’t select parent repeat values inside a condition.

Can’t believe that this is not being fixed for weeks. This is basic ui stuff and must not happen … :frowning:

Still not fixed. Any ideas when this will be fixed or fixed at all?

1 Like

We are still working on this one - it is fairly complex as it happens only on multiple nested conditionals