Problem with docker and Traefik

Wappler 4.7.1 (stable)
Win 10
Digital Ocean hosting

I make no secret I am not a big docker fan and haven’t used it much for 12 months. I have just tried to set up a site for docker deployment, all went well until i started to try and add SSL then i got an error
I have linked Wappler to DO, deployed to a droplet, set up the domain and all is well

I then try to add SSL via Traefik and get an error
I have tried both with and without dashboards

See video

Console output:
TypeError: Cannot read property ‘indexOf’ of undefined at A (file:///C:/Users/brian/AppData/Local/Wappler/resources/app/Shared/DMXzone/dmxAppCreator/UI/w2targets.js:8:89459) at file:///C:/Users/brian/AppData/Local/Wappler/resources/app/Shared/DMXzone/dmxAppCreator/UI/w2targets.js:8:73101 at Array.forEach () at Object.yes_callBack (file:///C:/Users/brian/AppData/Local/Wappler/resources/app/Shared/DMXzone/dmxAppCreator/UI/w2targets.js:8:68818) at file:///C:/Users/brian/AppData/Local/Wappler/resources/app/Shared/DMXzone/dmxAppCreator/UI/w2ui/w2ui.min.js:8:278213 at sentryWrapped (C:\Users\brian\AppData\Local\Wappler\resources\app\node_modules@sentry\browser\dist\helpers.js:75:23)

Also after the error, a second docker container appears in the list

Is this a bug or perhaps Wappler corrupted?

@George, @Teodor I hate to tag you directly but have you any ideas. Project has ground to a halt

Hi… @Hyperbytes

I had the SAME problem… and everybody thought i was going MAD!!!.. so i deleted all my comments…and just left a “delete me” title… and they deleted it… :slight_smile: :slight_smile:

basically it takes your local docker machine… … en “duplicates” the NAME…
but only the 1st folder name that comes up in the list… if you have 20 docker machines… 19 will come up correct… the first ones name get duplicated… as a “name”… to “namename”… see solution below for a quick fix so that you can atleast work… :slight_smile:


im still on version… v. 4.6.4

This took me a few hours to figure out why it did it… i still dont know why its doing it…
but a simple solution… that worked for me…

I went into my folder…


and then i just created a DUMMY folder… call it… aa or a or aaaa … just do that… just make a dummy folder with nothing it… so that your project name target name does not become double… dont ask me why … just do it :slight_smile: :slight_smile: it worked …

as long as the folder is the first one in the list… hence i made the folder name “aaaa” … then it duplicates the folder in as docker machine “aaaaaaaa”…

so even if i get an error on the 1ste one… i can at least continue to work… as i know docker machine/folder aaaa is nothing :slight_smile:

So this was the error…

without the folder…

With folder i created as dummy… i thought i was going mad… deleted and recreated my project on DO 5 times…

So add the folder… … and bobs your uncle…

That looks exactly like what I am experiencing. Stuck with a power cut (on mobile now) but will give this a try as soon as power us restored (down side of living in small village in the countryside)

lol… if you live is South Africa… you get load shedding… then you have between… 2 to 8 hours a day loadshedding…(power cuts)… our useless government… :slight_smile: Count yourself lucky to live in a small village… :slight_smile:

Yes, the up sides are far greater than the down although I wouldn’t mind some if your sunshine

Did you come right? did it work for you?

Still no power!

Thanks @Mozzi, that worked!

I am seeing the fake container I created in the list but now i can add Portainer/ Traefik to the desired entry.
That’s one bizarre bug, guess a pointer is not being set correctly somewhere in the process meaning whatever container is first in the list fails.


I have absolutely no clue what is going on…

Just tried it all myself and was working properly.

Do you have a new corrupted machine in the list? and the bypass - I don’t really get it …

well I might have found something! Happens only if you have just a single docker machine!

debugging further - at least now I can see the error :slight_smile:

ok found the problem - will fix it in tomorrows update.

PS. I hate ansi terminals - generating terminal titles on commands that needed to be stripped… hence the double docker machine names …


Great you found it @George I am impressed @Mozzi even found a workaround! This could potentially have hit every new docker user so could have been a nightmare

1 Like

Well this is a windows only issue and it seems to have sneaked in somehow with latest windows 10 updates as it wasn’t like this before.

Microsoft has updated their terminal to output all kind of crazy things that we now have to strip out.

Can you do anything about windows hogging port 80 and causing errors when adding SSL while you are busy (joking - i know it’s a windows issue, but it is a pain in the backside)

Looking at your traffic install reminds me also an important note that you have to remove port 80 from the regular docker site settings as traefik takes over.

So make sure you mentioned that in your videos.

Also if the docker site was already running on port 80, you will have to stop it first as otherwise traefik will give an error when trying to run also on the same port 80

So yes a lot of port 80 things :slight_smile:

Yes, well aware and including it all, don’t worry!

lol… it was a combination of … frustration… determination…and luck… that I found a work around…
As i posted the same issue before you… and got no response… and thought i might have done something wrong on my side… so i deleted the contents… because i dont want to to be flagged as “cry wolf” … because no one else got the error… so i thought i have done something silly again with my wappler installation or did some weird mod… hahahaha…

but anyway glad you came right… and thanks for “confirming” im not going “dilly”…

Thankful that @George could trace the error… and apply the fix… :slight_smile:

Sorry @george but still issues there

I removed the dummy docker machine as it should no longer be needed since the 4.7.2 update
I then stopped the docker machine and then restarted it and got a similar error to before

I restored the dummy machine and hit restart and it worked as it should

Guess you must have missed something