Large repeat tables don’t display since upgrade to 4.9.0

If a query used to “feed” a repeat table returns less than 100 records, the repeat table displays as it should… however, as soon as the query returns a large number (say above 250 records), the table shows NO rows at all. In other words, it is not limiting the records displayed - rather it simply shows NONE.

I verified that the query is returning all the data… as per the chrome developer pane and literally NO CHANGES to code… just the upgrade.

I don’t know if the following helps but… when I LIMIT my query to 198 or less records, the table works as expected. When I set the LIMIT in the query to 199 or more records, the repeat rows of the table do not display.

I should mention that I have tried this same “experiment” on several different data sets and found the 198 limit applies to all the data sets, regardless of the number of data elements within each record.

I can confirm this is happening. My magic number is different though. Luckily I haven’t pushed live yet.

Thank you for confirming. Just curious… what is your magic number?

I think I may have a different problem. Looking into it. I don’t seem to have a magic number.

My issue seems to be that my list can be filtered with a select menu. If the select does not have a value no records are being displayed at all now in the repeat. It is correctly displaying the 342 record count but is not showing the repeat rows in the table.

So, I may have also another problem and am digging further and may open a new bug report.

Wow, I’ve found the exact same problem with a select and the same magic number:

Any fix available? I have a large repeat dataset that is not working after new version!

1 Like

For what it’s worth, i have some repeat tables that can have large numbers, but i do not have a limit on the query so it does return more than 200+ rows.

As i said, this is without a limit in the query so that is a difference.

Also having the issue with large queries; waiting for fix

Could you check if this update works.


That seems to have fixed it for me :slight_smile:

Thanks Patrick.

This has been fixed in Wappler 4.9.1

This topic was automatically closed after 2 days. New replies are no longer allowed.