Workflows - Globals - add database query, cant open query editor

Wappler Version : 4.1.1
Operating System : Win 10
Server Model: Node
Database Type: MariaDB
Hosting Type: VPS

Expected behaviour

What do you think should happen?

Query editor should open when adding database query in Globals

Actual behaviour

Clicking query editor button does not open editor

See video

Just to add, i cant edit an existing query in Globals either

Are any of the queries there using Aggregate functions?

Scanned the global.json file and I don’t think so

Here it is (1.8 KB)

Please restart Wappler with logging, reproduce the problem and attach the debug log. See:

here it is (1.8 KB)

P.S. the “how to report bugs” post shows the old location of the log files
it is now, of course, at C:\Users\username\AppData\Roaming\Wappler\logs\wappler.log

You attached the same instead of the log file :slight_smile:

Sorry, senior moment :wink: (2.9 KB)

Ok found the problem, it happens if you use aliases in your queries.

Unpack the following dbConnector_rules.js (4.5 KB)

on Windows in:


on Mac in:
~/Library/Application Support/Wappler/Configuration/Shared/DMXzone/dmxServerConnect/rules

Make sure you place just the js file there not the whole zip!

Let me know if it works

It will be included with the next update


Confirm - that fixed the bug thanks

1 Like

I don’t have a Wappler folder in ~/Library/Application Support/

Is that definitely the correct path?

Don’t worry, found it. It was hidden under my user folder. So annoying that Apple have two places for Application Support!

1 Like

I had this problem and the replacement file enabled me to edit the query again. However, I think there is still a problem, at least with existing API files - conditions are being ignored.

I simplified the query. Here’s the condition and the query which is executed:

(the conditions are ignored)

I recreated the same query from scratch and it worked. I compared the two and it seems this is the problem:

I edited the non-working file - changing the quotes to ‘null’ and it worked.

It seems there could be a problem with existing files and conditions, which may not be fixed after the update is applied.

Thank you for this! I have not able to find the path and when you mentioned “hidden”, I knew exactly what to do! For those of you who are trying to find the folder on a Mac, hold the option key while clicking the Go menu under the finder.

1 Like

Please post a separate topic about this

It’s related to the main topic of the thread. I had the same problem - not being able to open Query Builder. I replaced the file with the new version and only then noticed the issue.

I don’t think it’s a problem with the current version, but with updated file (but I’m not quite sure) - so it’s not exactly an existing bug to report about.

This was fixed in Wappler 4.1.2

This topic was automatically closed after 23 hours. New replies are no longer allowed.