Unable to deploy Traefik on Oracle cloud server via Resource Manager

Unfortunately no
After clicking the Resource Manager Deploy (despite the presence of Alert’s Orange Triangle) Upload on remotely error

Ah seems you hit another bug in relation to the Oracle cloud servers. Will fix it in the next Wappler 6 beta update

Ok thanks, I await new beta to continue
Meanwhile, I try to understand why Oracle does not open those ports

Hi George
I downloaded the new beta and I immediately reconfigured the remote target
Finally both the development target and the remote target work, in the sense that the tests are passed and the result of the Index page is displayed correctly.

For the moment, the page is displayed remotely as not safe but I think you have to wait a few hours because Portainer and Traefik have effect.
In Resources Manager, however, Treefik remains present but Portainer is not displayed

I don’t understand what Server Control Panel, since it is not clickable

Last, now the ports 80 and 443 are open, but the ports 2376 and 9906 are still closed
Even if the project seems to work, I always wonder if the failure to open the IP ports can affect the stability of the site

We don’t use those any more. Docker goes now fully through SSH and port 2376 is no longer needed.

Also 9906 was only needed for direct database connection from Wappler you your docker database but that is also no longer needed if you just check “Over SSH” in the target database options.

Hi George
Ok for the IP ports

It remains a problem regarding Portainer
After more than 24 hours, the opening of the Index page on the web is still unprotected
In fact, it is strange that in the resource manager only Traefik and do not Portainer is present (I have tried several times to insert it)

Why do you need portainer?

I admit that I am not very informed on Portainer.
I believed that to make Traefik work it was necessary to set Portainer too
However, the fact remains that Traefik does not seem to work

No you don’t need Portainer for Traefik to work.

Check the linked article about using Traefik - you do need to add full domain names in your project target settings. and also add an email address to the Trafik options of course to let the Lets Enncrypt work.

Also once you deployed traefik successful, you can right click on it and choose to “Open Service Terminal” that should display stats and the Traefik log, so you can see if there are any problems.

the connection to Oracle Cloud Free seems to work well at the moment, but I have tried several times to configure traefik and the site always responds as not secure
Maybe I need to check in Docker?

Fixed in Wappler 6 beta 14

Just to clarify @Marzio now with Wappler 6 beta 14, you can run the “system check” from the context menu of your server and it will check and setup all firewall rules and make it secure. So there is no need for any additional server commands.