Tagify - Select mode won't work

Wappler Version : 5.0.2
Operating System : Windows 10 x64
Server Model: NodeJS
Database Type: PostgreSQL
Hosting Type: Docker

Expected behavior

After I click on drop-down - item should be added in tagify field.

Actual behavior

Item is not adding with mouse click but adding with Enter on a keyboard.

How to reproduce

I’ve already tried some updated version of DMXTagify mentioned here Tagify doesn't post values on edit unless changed - but it won’t help

Current Tagify options are:

Can you post the html it generated, the input tag with all the attributes. In your video I see you also adding multiple tags, this should not be possible in Select mode, it then functions like a normal html select.

<dmx-serverconnect id="serverconnect1" url="/api/sam/get_all_locations"></dmx-serverconnect><!-- Wappler include head-page="layouts/main" fontawesome_5="cdn" bootstrap5="local" is="dmx-app" id="test" appConnect="local" jquery_slim_35="local" components="{dmxTagify:{}}" -->
<meta name="ac:route" content="/test">
<div class="container">
    <div class="row">
        <div class="col">
            <input id="text1" name="text1" type="text" class="form-control" is="dmx-tagify" dmx-bind:data="serverconnect1.data.query_get_all_locations" tag-text="sam_location_code" tag-value="sam_location_code" nocustom="true" no-fuzzy-search="true">

Seems that I probably didn’t understand it correctly. I was thinking the Select mode wasn’t working, but it seems you don’t use the Select mode but the Default mode. It should indeed be adding the tag when clicking on an item in the dropdown.

I tested it and can confirm it is not working correctly. It seems that there is some breaking change in tagify v4.15 that breaks our implementation. For now use an older version of tagify, version 4.14.1 seems to be working. It is however a bit difficult to use the older version, Wappler updates the script tag each time on save, so you need to edit the page in an other code/text editor.

In the main page you will find the include

<script src="https://unpkg.com/@yaireo/tagify" defer></script>

replace that with

<script src="https://unpkg.com/@yaireo/tagify@4.14.1" defer></script>

I will investigate further on what exactly was changed in the latest version and publish a fix here when I have one.

Thank you very much - workaround with lower version worked.

Is it possible for Wappler to give the option of saving the tagify files instead of linking to unpkg.com? I remember issues in the past with Full Calendar where they made a change which then broke things. Storing locally would mean we’d be able to choose when to go with a later version.

Ideally, could we have the choice like we do with Bootstrap? Local/CDN, etc.

Perhaps @George can look at that, an option to choose between local/cdn could solve these problems. But we should also probably add the version in the cdn link, we added it also to the full calendar to prevent these kind of problems, linking to the latest version is not always clever.


Your initiative is already in discussion in this topic - Yesterday's cdn Tagify update broke it on all my Wappler websites

1 Like

Here an update for the select mode, please let me know if it works.

dmxTagify.zip (2.9 KB)

New version of dmxTagify fixed the issue.
Thank you, @patrick

The extension has been updated and is now available as an inline update in Wappler. This issue has been fixed there.

This topic was automatically closed after 4 days. New replies are no longer allowed.