“stripe” can’t be opened because Apple cannot check it for malicious software

Has anyone else had this issue trying to install webhooks for stripe on a M1 Mac. I am getting this error no matter what I do, even if I click allow install in security settings.

If anyone has a workaround it would be appreciated, as my work has now ground to a stop.

I had a hard time fixing it, refer to my topic:

@George I recommend stop doing “brew install” automatically due to this issue

Edit: Try running this in the Terminal:

sudo xattr -d com.apple.quarantine $(which stripe)

Well it is getting indeed more and more troublesome to auto install even trusted open source software on Apple MacOS because it is not always automatically notarised by Apple.

Happily our friends at homebrew have thought of that and introduced a special flag:

brew install --no-quarantine awesome-app

See
https://houtianze.github.io/brew/mac/2020/02/18/brew-no-quarantine.html

Will add it in Wappler for the next update.

2 Likes

One of the first things i do after installing my OS is turn off gatekeeper with the master-disable switch, and then change preferences to allow anywhere.
I would rather be very careful of what i install and run myself, then have to jump through the hoops the OS throws at me, even though i am pretty sure it’s really not a good practise.

Just one guys 2 cents worth.

Well actually Apple does two different verification checks. One for software being signed with gatekeeper and other more simple one - for everything that is downloaded from internet it is put in quarantine anyway - no matter signed or not.

So with no-quarantine or the xattr command above we are just avoiding the unnecessary quarantine of perfectly valid software.

I wouldn’t suggest to switch off gatekeeper- it is there for a reason - to keep you safe. And that is a must with all those viruses and ransomware these days.

1 Like

Thanks for the extra info, and yeah, even though i disable gatekeeper i still get tripped up by CodeSign issues from time to time, so Apple is certainly getting more and more secure.
I certainly know I should not turn it off, it is there for a reason other than to bug us i suppose. Maybe i will try it again in Monterey and see if its as painful as i remember it being in Catalina

Yep using

sudo spctl --master-disable

did the job for me :slight_smile:

This has been fixed in Wappler 4.5

1 Like

This topic was automatically closed after 30 hours. New replies are no longer allowed.