reCaptcha Error

Hi all,

So I have been offline for the last few months due to Covid.

Now when I downloaded the latest version of Wappler, updating from 3.2.0, and updated my projects, I now get an error with reCaptcha.

Now, If I roll back to a backup before the files updated, I can login without any issue with reCaptcha.

Any help be grateful,

@Teodor any change you can help with this error?

What server model are you using? What have you changed on your page? When do you see this error?

Hi @Teodor,

I am using ASP.NET server model.

I have changed nothing on the page.

I had created this site(login page) when using a much older version of Wappler.

When I opened the site this week using the new version of Wappler and saved the page, it pushed a load of new BIN files to the test server. This is when I get the error.


@Teodor I just went to try and use reCaptcha again and I still see this error.

Can you help with identifying why it’s throwing an error?

Server action

Page element

Form data


Platform - Wappler 4.2.2

I have never been able to use reCaptcha because of this issue but I’m sure it’s something simple that I am going wrong.


There was an other post with the same error, it seems that somehow the module is not found, it works for a while and then stops working. I have no idea what the cause is, I have recompiled the module which maybe helps, here is the update. (4.1 KB)

Thanks, Patrick, I’ll try the files in the zip now.

Ok, dropped the files into the BIN dir.

Launched Wappler and saved the SA again.

Now working as expected.
Image from Gyazo

I have just looked at that other post and it seems that the fix was not permanent for @markoax21

I’ll let you know if mine starts to throw up the error again.


Thank you for your post!
I had given up, I thought the problem was only mine.
Now I’ll do some tests and let you know.

I keep having the same problem. It works for a while, then not anymore (same error reported by @raymantle)

I’ve updated the code how the assemblies are being loaded, please test with the following updated files. (52.1 KB)

Hi Patrick

I was just about to post, the issue is back. Has been working fine since I posted but just went to check now, and I’m getting the same error again.

I have verified that the files have remained unchanged since I drop in the new files this morning

Will try the latest zip file you just put up.


Hi Patrick,

No Change even with the new server connect files.

I have confirmed the files have been update on the server.

You can try the URL I just DM you and I have debug enabled.


No changes even for me

I think that I am figuring out what is the problem. Here are new updated files, also be aware that the recaptcha dll file was renamed, please delete the old file. (56.4 KB)

Hi Patrick,

OK, delete the old file and updated Wappler with the new ones.


Provisionally, reCaptcha is working again.

Will keep checking over the new few hours.


Well, 16hrs later and it’s still working.

I have marked it as the solution but will keep an eye on it today.

Will these files be included in today’s build?

Thanks @patrick


There won’t be an update today, but these will be included in the next week’s update.

Thanks Teodor.