Problem running Custom Query in SC

Wappler Version : 3.4.2
Operating System : Mac OS
Server: PHP & Docker

Expected behavior

What do you think should happen?

Running a custom query in the editor retrieves the Schema

Actual behavior

What actually happens?


It seems the queries still run when the SC is used (I have pages that still work that use SC connection that rely on Custom Queries that work fine). In the Custom Query set up, though, the queries can’t be run and therefore the schema can’t be retrieved. I have tried for queries that are more complex, but I know work because the work for the pages that call them, and for a very simple query (as above)

I am using 3.4.2 and PHP

How to reproduce

  • Detail a step by step guide to reproduce the issue
  • A screenshot or short video indicating the problem
  • A copy of your code would help. Include: JS, HTML.
  • Test your steps on a clean page to see if you still have an issue

Create a Custom Query step in SC, add a basic query and cluck the run button to retrieve the schema

Not sure what could be wrong with your query i tested this on abrand new Server Action and it works fine:

Maybe @patrick can check this.

1 Like

I also checked it and it works fine. Could you please provide some extra information. What is the target that is selected, are there any errors in the console?

Thanks @patrick,
The target is the dev server (built on AWS with Docker - using the Wappler project settings). This is server-side on PHP so no console issues as the query will run if called externally, it just won’t run from the Wappler UI. I have switched to the production version and get the same error.

Could you first update and redeploy (just click on Deploy). Does it only fail in the Custom Query dialog?

This is it in the UI

Here’s the result on the page (successfully returning data):

Very weird!

Please restart Wappler with logging and send me the debug log file.

I’m having the same problem…both on UI and on production…HELP!

Fixed in Wappler 5.2.0

This topic was automatically closed after 32 hours. New replies are no longer allowed.