MySQL 5.6: Problem fetching database table columns - takes long time

OS info

  • Operating System : Windows 10.0.19041
  • Wappler Version : 3.7.7

Problem description

database fields not available since upgrade. I was woking on the same page earlier then after the upgrade I get this

Steps to reproduce

  1. open api
  2. select query
  3. select query builder (263.5 KB)

Make sure your connection is properly defined in the Database Manager.

it sets up and tests ok (always has)


in database manager i get this (always hve)


The database has always worked in the server connect despite these issues, not today

i set up another database connection to test and it has the same behavior

Well you should have reported it, as database manager is now required.

What database and server model are you on?

Really? Check my history, I’ve reported it before


Well if you can point me to the report and also generate a new debug log with the error as the above zip file doesn’t include any debug log

I just created a new one

Your zip doesn’t contain a debug log.
Make sure to follow the instructions here:

even when I restart with logging the zip file only contains a screen shot, no log

Just lookup the log file on the location indicated in the topic and include it here manually

chrome_debug (2).zip (5.6 KB)

Could you produce a new debug log file that includes you going to the database manager and refreshing your database schema, by selecting the database connection and clicking on the refresh icon in the toolbar? Thanks

chrome_debug (3).zip (4.1 KB)

Your database is very badly accessible, the schema query gets a lot of timeouts on each table query.

Is your database accessible at all with direct connection?

I have another project that has a similar database connection php-mysql-hostgator and it works. It’s the first I’ve ever seen it work. I added this database connection and it also takes a while to load and produces the same result

Well you should really make sure your database is accessible and is running well because it seems to me that you are on way too overcrowded shared hosting.

It takes ages to run a simple database query.

Your database server is clearly overloaded.

Maybe consider to switch hosting.

that seems extreme, is there a way to test/troubleshoot the database? I hate to change and migrate everything, I’ll check with HostGator to see if they can performance test the database

why are the connections screens different between the server connect are and the database manager area?

chrome_debug (4).zip (4.1 KB)

I deleted all but 2 of my databases and exported this to a new database and reconnected. I’m able to use the data in server connect now but database manager still shows errors, here is the newest log

Wappler v3.7.6 (I haven’t yet upgraded to 3.7.7 after coming across this issue)

I have had the same issue since the databases have been moved to Globals. Even though the database connections are not showing tables/views under DB Manager, the SA are working correctly.

I have deleted and re-created the database connection that is showing errors. When testing the Direct Database connection, I’m getting a timeout error and I’m getting Unable to connect... error when DB Manager is refreshed. All SA related to this database connection are working correctly even though the Direct Database Connection is failing and unable to fetch Tables/Views.

Screen Shot 2021-02-19 at 10.56.13 am
Screen Shot 2021-02-19 at 10.02.17 am

1 Like