MSSQL Re-edit of Query & Paged Query with View does not work

======== TEMPLATE BUG FORM ========

Wappler Version : 3.7.6
Operating System : macOS Big Sur
Server Model: NodeJS
Database Type: MS SQL
Hosting Type: Custom

Expected behavior

What do you think should happen?

After creating a query from a view it should be possible to edit it again.

Actual behavior

What actually happens?

On edit of the query (or paged query) I get the following error:

How to reproduce

  • Detail a step by step guide to reproduce the issue
  • A screenshot or short video indicating the problem
  • A copy of your code would help. Include: JS, HTML.
  • Test your steps on a clean page to see if you still have an issue

Create a query or paged query from a view and try to edit it after saving it.

Please restart Wappler with logging, reproduce the problem and attach the debug log. See:

Here my log file: (2.9 KB)

How did you query look like?

Pretty simple:

tried it with all kind of tables in MS SQL Server and it works all fine to me…

could you try to recreate it?

I already tried it a couple times. I will experiment with a simple query.
If I copy the query in the custom query it does work without error. It does only happen if I use the view.

Could you add the generated action file as code block?

@George Could you replicate the issue?

This has been fixed in Wappler 3.7.7

This topic was automatically closed after 45 hours. New replies are no longer allowed.