Error refreshing schema database "cannot read property 'refs' of undefined"

======== TEMPLATE BUG FORM ========

Wappler Version :4.9.0 and 4.9.1
Operating System :Windows 10
Server Model:
Database Type:remote MariaDB 10.3.34
Hosting Type:VPS

Expected behavior

What do you think should happen?

error message “cannot read property ‘refs’ of undefined” appears when I try to refresh schema at database connections

Actual behavior

What actually happens?

After add new tables to MySQL remote database and press with right button mouse refresh schema appears the message error and no new tables are added. It happens with the lastest versions of Wappler. If I uninstall the last version (tried 4.9.0 and 4.9.1) and install 4.7.3 it works OK (I only have this version in my HD to install) no error, refresh works well.

What is your database structure and was it created with Wappler’s database manager or external tool?

It is a MariaDB 10.3.34 database hosted in a VPS remote server with 37 tables. Some of them n:m relationship. I don’t know if you are asking this or more information needed. It was created with HeidiSQL tool and it was in use before I started programming with Wappler.

Maybe send me the database schema as sql file in a private message and a log file of the error:

restart Wappler with logging, reproduce the problem and attach the debug log. See:

I have the exact issue but only one one database.

I have solved it uninstalling and deleting the Wappler folder on Windows and doing a new clean installation with Wappler 4.9.1