Error - 'Cannot read property 'parent' of undefined ' in 4.8.1 and 4.8.2

Wappler Version : 4.8.1, 4.8.2
Operating System :Windows
Server Model:
Database Type: PostgreSQL
Hosting Type: LocalHost

While opening any query the query builder is giving following error -

Make sure that in the Database Manager, you define a direct database connection to your database.

See also:

I have a direct database connection, which is testing ok.

Can you see and refresh the database schema for this connection in the Database Manager?

These are the options I have -

Can’t see the database manager as in the screenshot from you above. I have tried refreshing it.

Yes that is it - seems all fine.

Try expanding the schemas and see if the tables are all there

All tables are there and connection is testing ok, but still the error remains.

Only Database Custom Query can be opened. All other queries like Database Update, Insert and normal Database Query are giving this error.

Make sure to switch back to your development target if you only have the direct connection set up there, otherwise switch to your remote Target and set the direct connection there as well and that should help the error.

When I have that problem, I can refresh the schema of the database and it will work. Testing the database alone will not make it work.

I am not on the current Wappler update 4.8.2 yet so I can not really speak to those errors I am still on 4.7.0. But do you have a Workflow setup already that allow you to insert any data into the database table that you are trying to View/Edit Data for?


I tried disconnecting and reconnecting to the remote DB. Now it is giving following error. DB connection is working from my SQL tool.

facing same problem. checked that DB conn on globals and direct db conn both are good.
am on Wappler 4.8.1 on MacOS.
project is NodeJS with PostgreSQL 13.
any luck with this issue?

This has been fixed in Wappler 4.8.3

This topic was automatically closed after 2 days. New replies are no longer allowed.