Digital Ocean Resize - Docker stopped

Hello everyone!

I resized my Digital Ocean server and docker is not connecting anymore.
Accessing the console on Digital Ocean, and typing: docker -ps I receive this error:

Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

Did anyone face this problem before?/

On Wappler manager for docker machines, I just have this below:

Thanks for your help!

Is the IP address of your server still the same? It might have changed after the server resize and reboot, if you don’t use floating ip

Hey George! I’m not using floating IP! How to check if the IP changed?
The IP I have on DO panel is the same of the Wappler target config…nothing changed…

Yes you can see the IP in the DO dashboard.

Is the server running and the website accessible in the browser?

The server is running, I can access via console. But the application is not accessible in the browser because the docker is stopped and it is not restarting anymore.

Well maybe try to restart the server in the DO dashboard.

tried already…no success…

Maybe you should try the DO support.


Ran: dockerd --debug and the result was:

INFO[2021-11-19T17:18:44.246115949Z] Starting up failed to start daemon: Unable to get the TempDir under /var/lib/docker: mkdir /var/lib/docker/tmp: no space left on device

There was no space in one folder (vda1), I cleaned with:

sudo find /var/log -type f -delete sudo rm -rf /var/cache/apt/* sudo apt clean all

And then sudo systemctl restart docker

Docker running again! So I redeployed and all working now!


1 Like

If you haven’t limited log space usage, this might be useful