Cryptographic insert not applying (formatters closing and not applying formatting)

Wappler Version : 4.6.4
Operating System : Ubuntu
Server Model: Node
Database Type: MySQL
Hosting Type: Docker
Update Channel: Stable

What do you think should happen?

When applying a cryptographic formatter to a post input for insert it should be applied to the input.

Actual behavior

Dialogue closes returns to insert with no formatter applied to the post input.

  • Add Server Connect Insert.
  • Select input.
  • Apply formatter.

Have done this hundreds of times and this has recently started occurring? The dialogue simply closes and it is impossible to add a formatter. Happens front and back end. It is a HUGE issue and causing significant inconvenience.


This happens client and server side, even something as simple as trying to format a date to ISO closes without applying formatting on the front-end, and back-end the above is happening with essentially every attempt to format data. Have removed and reinstalled Wappler, latest version installed. Like I mentioned this is recent, in the last two updates or so (initially I thought it was a bit buggy but now it is a constant bug hence the report). Has got to the point where multiple Projects are on hold due to the issue.

Running Stable Update Channel release (maybe this should be added to the Bug Report criteria, what Update Channel is in use?).

I can’t recreate this on Windows, running the latest version. The formatters are applied without issues. Maybe it’s a Linux only issue?

We do not have any Windows machines here to test/work on. Originally it begun as hit and miss (if we switched the binding to code view and applied the formatter it worked 9/10 times) an update or two back but now it is a consistent issue. Just checked on a PHP Project that was built on Linux and the formatters applied on Linux and the same issue as displayed above now exists.

Can you run Wappler in debug mode, recreate the issue and attach the debug log here?

Of course. Give me a moment and shall provide the debug log. Thank you Teodor.

I’ve searched my entire drive for chrome_debug.log and it does not exist despite starting with logging. Have tried to submit error report but no idea if that was sent @Teodor?

All that is contained within the report is a single screenshot. (59.5 KB)

An update of sorts. If the cryptographic formatter is applied to a Security Provider input such as a security login input it applies the formatting as expected, but for all other formatting purposes it does not, simply reverts to the original input with no formatting applied.

Looking at timestamps on files the last time formatting worked correctly in Linux was on the 14th February when the same cryptographic formatter was used on a previous registration insert with no issues as reported in this bug report. Not sure if that helps any?

Any hope of a fix for this issue please gentleman? Its almost as if the Select button in the Data Binding panel is acting as a close button on Linux, where as the Format button is actually closing properly and maintaining the formatting (and is lost when the Binding panel is closed).

@George @Teodor

Could you confirm this is being investigated by any chance please? Everything was fine prior to 14th of February. Have done the usual uninstall, clear everything, re-install, try again, same issue. Am at the point where this issue is having a knock on effect for a Clients schedule now and is quite urgent to be honest. As always appreciate any feedback, thanks in advance!

@dave just saw this and can empathize in general

I have access to a Windows machine I rarely use that has only Wappler on it and a few MS Office apps. No client data is there, and I am planning on doing a clean install on it soon.

If you need to test or temporarily workaround this issue for your project on Windows to avoid missing a deadline, let me know and you’re welcome to use our Windows Server 2019 system remotely for a day - send me a PM if this would help you.

1 Like


That is really kind of you to offer, thank you. Unfortunately I can’t accept as the Project contains a lot of sensitive information (I’m not insinuating that you would in any way interfere with it by the way), it is also quite extensive.

This bug is a real pain in the arse as writing out complex sums without the formatter is simply impossible, that is one issue, then there are a dozen others involving arrays, general formatting, the cryptographic side I got around by simply copying the expression from another Project, so at least resolved that.

Hoping it will be resolved in today’s update…

Thanks again though, really very appreciated indeed.

1 Like

A wise choice anytime there’s private info! Totally get it

1 Like

Could you check if this happens in the latest Wappler version 4.7.1?

Have just done this @George, and yes it still occurs, but the application of formatting to Security Login is fine. Thank you for responding. I’m sure it is to do with the button action in some way?

You can see by the video it just closes both windows upon application.