Code appears in inactive file tab

Wappler Version : 2.4.5
Operating System : Mac 10.14

Expected behavior

Typing code in a file should appear in that file.

Actual behavior

The typed text is added to another file open, but not active. The blue modified dot of the inactive file changes to indicate the file has been modified, even though it is not active.

How to reproduce

I have not been able to consistently reproduce, so attaching a video illustrating issue. When the style.css file is open, it appears nothing is happening, however I am typing letters.

code edit.mov (4.6 MB)

1 Like

Same issue seen, i assumed the file had gone read only. Restarting wappler normally fixes it (temporarily)

I am aware of this problem, but at this moment I was not able to find the cause of the problem. It seems not to happen very often and very random, also we were not able to reproduce the problem after we encountered it.

It usually happen when you write to your active file and nothing is being typed. So all of a sudden, you will see your typos on another file header and thereby creation runtime errors.
Solution is to check as you type, if nothing is typing, close the file without saving it or simply undo the last changes.

Maybe it happens with specific files combination and switching of tabs? It will be really helpful if you can provide a step by step so we can reproduce it…

Will simulate it and send it shortly

Thanks - it will be the most helpful if you try to reproduce it from the Wappler start and then open this and this file, edit etc till it happen

Hi George,
I have tried to reproduce as promise. But it is been very difficult. What i noticed is; if a page is in code view and you try to edit another page in the code view especially css, the last code view page will becomes active, locking the current one, so whatever you are typing will write at the header of the last active (with blue em). One need to look up to see it nothing was writing. At that point, just go to the active/recognized (with blue em) and delete whatever written AT THE BEGINNING OF THE PAGE

I’m convinced this is related to a .css file edit now. Just happened again to me on 2.5.0

I was working in a brand new blank mobile project with framework 7 and cordova only.

Best I can recall:

index.html was open and recent changes not save.
Opened index.css from css folder
Tried to edit css and found my typing appeared at the location of my last edit in index.html

1 Like

This should have captured the problem.

1 Like

Just happened again with a javascript file open, and the results ended up in html file…so not necessarily a css thing.

I am on the windows version of this. And have been having the same issue.

Its when I am editing code in either code view or split view and it will add the text to another page that I have open. When I go to the page that it is actually writing on, and I delete that text, when I go back to the page I was trying to edit it will then allow me to edit that page again. Weird.

Hi @ George, it only happens to me when I have pages open and then I edit a .css file. it normally edits the file (tab open before the .css file tab).

I had this today also, Think i need to run in debugging mode all today and see if I can capture this. It isn’t always linked to css files but this seems to be the most common trigger for me.

We are aware of the problem and I also had it once, I was able to debug it to the Monaco editor, but could not find the exact cause. Also it is very difficult to reproduce, couldn’t reproduce the case after I had it once. It is also not specific to css files, it also happens with other files. It get fixed when you focus the editor where the edits are applied and then go back to the other editor.

From what I currently know is that it seems to be some focus problem with the Monaco Editor when there are multiple instances of the editor. It can even happen with multiple (more than 2) tabs open, all edits come in a single editor instance. I checked the public API of the editor and it seems to set the focus to the correct editor, but still it places the edits in the incorrect editor while the focus, copy and other editor specific actions work on the visible editor.

Actually it seems is a known Monaco Editor problem, but the guys from Microsoft aren’t solving it soon as they also have troubles in reproducing it …

See:

Just reporting here what was discussed in a separate thread. I routinely have this problem - it seems most of the time when I try to edit a file that’s not generated through the Wapper UI (eg I open a PHP or XML file). It drives me to use an external editor and swap between Wappler for the graphical editing and external editor for code editing which isn’t a great experience unfortunately.

Is there an expected resolution for this?

This has been a serious problem for me since the Monaco editor was a added. At first, random sections of code on files in tabs without focus were being wiped out without my noticing. Then after some Wappler updates over time I settled into what is described in this thread. Namely, for random reasons the editor inserts what I type on another open file but not the one with focus. Over time with updates this has become less frequent but it still occurs. I cannot figure out the circumstances to trigger it either. I have just come to know that when I don’t see anything when I type I look at each tab to see where it inserted the text and I fix it. Then I restart Wappler. It used to happen every few hours or so but now I can go a whole day with it happening about once. Then again, I am in the habit of restarting Wappler every 3-4 hours anyway. I wish I could say how to reproduce it but I cannot. I am using a MAC.

Same here and in version Beta 3.0 seems to be worse!

it appears that even if you save all and move to a different tab any page editing shows the previous tab as being edited and changes required to be saved.

Using a MAC.