Calling Stored Procedure Error


When I call the following MySQL stored Procedure using a Custom Query I get the following error;

Cannot read properties of undefined (reading ‘name’)

Can anyone explain why?

Many thanks

There appears to be a typo in the query syntax. P:1 instead of :P1

Thank you for looking. I have corrected the typo but still get the same error.

Have you defined a direct database connection in the Database Manager?

Yes I have.

I mean in the Database Manager panel

Yes, there is a direction in there.!

And when you test it - is it also fine and do you see the tables there?

Yes, all seems to be working fine.

If you need me to ask the developer of the SP anything please let me know.

Hi Teodor,

Are you able to shed any light as to what the error, (reading ‘name’) is referring to?

One more thing i see here is the syntax - it should be without the quotes around :P1

Hi Teodor,
I have tried it with and without as per another post I found and I still get the same error.

In phpMyAdmin the SP executes OK and returns the expected values so I don’t understand what the (reading ‘name’) is referring to.

Maybe @patrick can help here.

Does the SP work when you have no parameter?

Unfortunately not and that id number works within phpMyAdmin and dbForge query mySQL builder

Do you see an error in the Wappler console? Please start Wappler with logging enabled and send us the log file.

Could you also try to turn the experimental options on in Wapplers Global Seetings / System.

Then try again.

Have uploaded bug report