Bug Report #1648574121736

OS info

  • Operating System : Windows 10.0.22000
  • Wappler Version : 4.7.1

Problem description

Notification Error executing query: e.substr is not a function

…Error when requesting data from the database tables, SQL Database

Have tried making a new app same issue once connected to the database
Have tried connecting to a different database

Steps to reproduce

  1. Connect Sql Database
  2. Click on View/Edit Data
  3. Click Fetch Data

Could be related to these?

There seems to be an issue with the current upgrade and the connection to a MS SQL database, I have try just creating a new app with just a connected database and had the same issue.
The Direct database connection does not show any errors.

This could be an issue with the table name aliases when creating/saving database queries. Try running the queries after removing/deleting aliases in the DB Query Builder. You may need to remove the aliases again after making any changes to queries, as these get re-added.

Yes the queries are not able to pull the information however the problem is occurring without any queries, I tried an app with only the database connected and nothing else. I tried a view/edit directly on the tables which produce the error. I have checked the tables and there doesn’t appear to be anything wrong, the other issue is that the tables worked on a pervious version of Wappler without fault. The database is a Microsoft SQL, I am interfacing with ASP.NET

I just tried view/edit/fetch data on a table in the Database Manager and it displayed the rows correctly. I am running the latest version.

Have you tried creating an API action and run a simple query by selecting this database?

I have spent a bit of time going through and having a look it appears that it may have something to do with the dbo. at the beginning of the database names, I have some customized queries that do not have the dbo. in the sql and they run like a dream. It appears that the sql does not like the DOT in the sql statement. There is the odd case where the dot did not appear to matter, which has lead me to some confusion.

Yes you can just rename the alias to be without dbo. As ms sql server doesn’t like dots at all.

This has been fixed in Wappler 4.7.2