Bug or technical issue? Sudden error in my database/tables

Hi Wapplers all the way from Sydney Australia,

Im having a problem which is driving me nuts. As I opened my project I received the followin error when I clicked on one of my database tables to view the contents:

Its basically telling me no tables or users exist when in fact they do. Any idea how to resolve this? I tried restarting services and closing wappler and reopening. My stack is as follows:

NodeJS,Postgress, Docker

It’s worth noting I had docker issues which is now resolved but I had to reinstall a new version of docker.

Its also worth noting this error also comes up when I pull a version from Gibhub on another device and the other device does not recognise the tables either.

Any help would be greatly appreciated as I am currently stuck.


I’m not sure if this will solve your issue, but might be worth a try while waiting on a response from others.

Could you try restarting Wappler and Docker? I had an issue recently with another error and restarting fixed it.

Did you run your migrations? The Wappler view doesn’t refresh in real time, the tables might not be present (anymore) due to other issue(s) (such as erasing data/volume of a Docker container)

Thanks for your response. How do I run migrations?

Didn’t work… thanks anyway

Thanks I will try that. If that doesn’t work it means I deleted docker container. If I deleted a docker container is there any way of fixing this issue?

If that doesn’t work you have bigger problems :rofl: So you better check if that works first

P.S.: Deleting a Docker container is not a problem, it can be re-created by clicking Deploy

That didnt work. Gave me the following error…

Delete the database by clicking the shutdown button near the Deploy button, and then Deploy and run the migrations (Changes) again

If you still have a problem then somehow your migrations got messed up and you have to fix or re-create them. I once helped someone here on the forum with the same issue, hope you can find the topic

That didn’t work unfortunately… will try find your previous topic

If I just re add the old tables again will everything go back to normal?

This is the topic:

You could re-create the tables/columns starting from where the issue started to happen

Thanks… how do I avoid this from happening in future?

Hard to tell because we don’t know what caused your issue in first place, only thing we know is Wappler wasn’t totally in sync with your database and that caused issues when you made new migrations

Vote for the feature requests:

Thanks will do. This is not the first time this has happened to me and it’s made me quite anxious building on Wappler as it paralysis my app … hope they fix it

Okay I know what cause this problem, and I think it’s a huge bug. Here is what I am doing to replicate this issue:

On macbook 1:

I rebuilt the table objects again. No errors popping up. I commit and push the update to github.

On macbook 2:

I clone this project, and as soon as I open up the tables, the same error pops up on this device. I refresh the schema and all the tables disappeared.

So the problem is pulling and pushing from github- the tables are not synching.

Unless I a not doing this correctly?

You haven’t run migrations on your macbook 2, right? You have to run them first

I’ll ask the team to add some safety check regarding that

I thought I did…

My steps were as follows on Macbook 2:

  1. Open up Wappler and click on Clone project from github
  2. Project loads
  3. run migrations - error pops up migration failed.

Reason the migration failed is because the tables are not synching…

Oh, ok, I understood that now. Well, that might’ve happened because you had to re-create some of the migrations as they were erroneous in first place, so I wouldn’t consider this to be a valid replication of the suggested bug. If you confirm both computers are with the project exactly at the same (working) state and you try to to create a migration, do a Git clone, run migrations, and you still see that problem, then that’s ok to be considered a (possible) bug

Edit: Have you modified .gitignore? Maybe excluded “db” from Git? I had that once happen to me

Edit 2: Sorry, you can discard my reply, I missed the part where you said you cloned the project (instead of pulled the updates). The investigation of this issue would take time I don’t have at the moment