Auto Submit always checked

windows 10
wappler 2.3.1

create simple insert or update form then you will see the auto submit checked .

I think this is the same bug (at least in part) mentioned in these topics: here and here.

no it is different. @TomD

I meant they all have something in common: checkboxes which were previously working correctly are no longer doing so - eg they’re automatically selected when they shouldn’t be.

1 Like

Same for the form generator also.

Confirmed, auto submit will always default to checked upon refreshing of the App Structure, however, I did not see any changes in the code view when it occurs.

1 Like

This appears to be happening with all check boxes. For action scheduler No Repeat and No Auto Run are always checked on refresh.

I have found this to be quite annoying, but don’t know if is only happening to my computer. After setting up a form with app connect and selecting a server action the “Auto Submit” check box keeps habitually getting checked on its own. After i uncheck it and make any other adjustments to the page it appears checked again. I didn’t realize it until after uploading the form it would auto submit because it rechecked itself. Is this a bug?

Initial report of a bug here:

Even if you de-select Auto Submit and save the page it reverts back to Auto Submit upon opening the page again (displays ticked but Auto Submit does not appear to be applied).

Hi All,
we’ve identified the problem in the UI and will fix it is in the upcoming update.


You da guy! thank you Teodor!

Fixed in Wappler 2.3.2

This topic was automatically closed after 47 hours. New replies are no longer allowed.