4.8.0 DB Manager Error on Schema Refresh

I now get an error on schema refreshing. I can replicate this on all projects. I normally don’t use the DB manager at all other than schema refreshes.

Server: PHP
Database: MySQL

How do you execute the refresh? From the context menu or the icon on top?

Context Menu …

Screen Shot 2022-04-14 at 11.23.25 AM

Not sure if related but on schema refresh getting this error

Version 4.8
Windows 10 Pro

1 Like

I should also add that if I Quit Wappler and restart it the error goes away until I refresh schema again.

Now, after updating to 4.8.1 refreshing schemas is totally broken and unusable.

Now I suppose I am out of work until this can be fixed. My project is at a complete standstill until I can bring my tables and views into Wappler.

I am not a happy camper today.

Is this only on some special database connection only? Is it a direct database connection and where is the database located?

We couldn’t really replicate the issue.

Do you see any errors in tge publishing panel below?

Please restart Wappler with logging, reproduce the problem and attach the debug log. See:

Nothing special about it. Happens on all projects. Database is located on remote server. Tables and Views created in Navicat.

Before, I had to have direct connection set up to get it to work. Now I have turned off direct connection and it seems to work.

In order to inspect and refresh database schema and tables in the Database Manager you need a direct connection, Brad.

Then it is definitely broken. With direct connection turned on, the db manager is completely useless when it comes to refreshing the schema. I had to turn it off to get it to refresh,

Where/how do you turn it off? Connections made in the database manager are direct connections. If you delete them, you don’t see the tables in the database manager.

I had to turn it off in the global connections.

Brad this is an option to just create also a direct connection in the database manager.

You control the connections in the database manager directly not in server connect.

So check your connection options there.

If I click on the direct connection button in the db manager the settings are now blank and I can refresh the schema. But I had to turn it off like in the previous screenshot to get it to work.

Anyways, although it isn’t working as it should I have found a way to work around it and can continue working for now. Like I say, I only use the db manager to refresh schemas when I add a new table in Navicat.

Well Brad seems you never have used a direct connection to your database in Wappler’s database manager.

Just enter your connection details there, test and save.

Again, with that all the settings filled in the db manager will not refresh schema. I had to clear it to be able to continue work. It used to be all filled in and worked fine until 4.8.0. Now I have to clear the settings to be able to work.

That’s what I am trying to say. With direct connection set and filled in (connection tests ok) the schema can’t be refreshed.

This needs to be set up for the database manager to see/read/refresh your database structure.

Well, clearing it works. So I don’t know what is going on. I clear it by turning off the toggle in the globals connection settings. As long as that is turned off it works.

Anyways, I can work again. I only use db manager to refresh schemas. So it’s all good. Go have a :beer:. It can wait until ext week now. Enjoy your weekend.


Well you really should use direct connections in Wappler, Brad for the database manager. Then you can fully empower it for managing your database schema.

This is its main power for a while now.