When execute custom query, 'Unexpected token' error occurs

Wappler Version : 4.7.3
Operating System : Windows 11
Server Model: NodeJS
Database Type: PostgresQL
Hosting Type: Local

Expected behavior

Click the ‘Execute Query’ button within a custom query, get the output plus automated schema.

Actual behavior

How to reproduce

Click the ‘Execute Query’ button within a custom query

Just set up a local postgresql server running postgresql 14 and set up a simple table.
Testing this on a local nodejs project - a simple query like the one on your screenshot runs perfectly fine:

I really cannot recreate this issue on NodeJS with PostgreSQL database.

My database is hosted on AWS RDS. It is accessible from local web server, and the Wappler database manager works well. Only custom queries are not executed in ‘build query’. I can check the query data responded by local server

I tried it on another desktop that didn’t update to 4.7.3, and the custom query runs well. I want to share what is the current version, but I don’t know how to check it.

Running heavy queries on other computers also results in bugs. Deleting and reinstalling the Wappler also results in a bug. After saving the file to a remote git, I even tried to create a new project.
It’s so hopeless. Please check my error report.

report1649267665690.zip (150.2 KB)

Fixed in Wappler 5.2.0

This topic was automatically closed after 32 hours. New replies are no longer allowed.