Wappler Update Fails in Mac

======== TEMPLATE BUG FORM ========

Wappler Version :2.3.5
Operating System :MacOS 10.15

Expected behavior

updaters should download and install


Install error
Must download and install directly for latest and several past updates.

Just out of interest I am still on 10.14 and the install procedure works perfectly still. Probably a 10.15 related issue

Do you get any specific error?

I just saw this Problem Updating Wappler on MacOS

Same as that one.

Follow this then:

Wappler-Mac-2.3.5.dm Resource busy

Hi @George,

I got the same error that Howard reported when opening up the dmg file directly from the location listed.

Hmm does finder shows any previous Wappler install disks mounted?

Maybe something like:

Nope, I eject and then remove the dmg files to Trash once I install them.

No it doesn’t.

Use hdiutil info to check if the image is already mounted, if it is then use hdiutil detach {dev_name} -force to unmount (replace {devname} with the actual moun path like /dev/disk1).

Unmounting via disk utils normally fixes the issue for mez

As I already stated mine worked fine, I did out of interest try to mount the DMG file and also had no error at all.
I did a checksum on my download with

md5 ~/Library/Application\ Support/Wappler/temp/Wappler-Mac-2.3.5.dmg
Returns: 578a7913b5899321034502d6d6e0991f

ls -l ~/Library/Application\ Support/Wappler/temp/Wappler-Mac-2.3.5.dmg
Returns permissions of -rw-r--r--@ and the file owner is set to staff

Dont know if any of that helps narrow anything down, but maybe.

I never noticed that the dmg file was retained in the Disk Utility after ejecting and trashing it. Odd that it should still show up in Disk Utility.

I removed it from the Disk Utility, but as I already downloaded the update from the website, I’ll wait until next week to see if that resolved the issue.

Yup it was in disk utility.

This has been improved in Wappler 2.4.2

1 Like

The the update notice, download, and update worked perfectly today!

1 Like

This topic was automatically closed after 46 hours. New replies are no longer allowed.