Wappler 4 Beta 6 Targets Getting Stuck

Wappler Version : Wappler 4 Beta 6
Operating System : Mac OS Big Sur
Server Model: Node JS
Database Type: My SQL
Hosting Type: Docker

Expected behavior
The targets should switch from development to remotes and vice versa

Actual behaviour
The targets menu gets stuck on what’s currently selected the menu will stay open till clicking off the pop up area

How to reproduce

I’m not entirely sure why this happens the first time I just quit and restarted Wappler and assumed it was just a glitch and a refresh would solve it which it does fix for a while after restarting but it just got stuck again

The first time I was editing my database schema on development tried to switch to apply changes to the remote but was stuck

The second time I had just finished a server action tried to switch to publish to remote and wasn’t able to

Update seems to be caused by having a server action tab open while attempting to switch targets closing the tab allows me to switch