Wappler 3.9.4 on Linux - dependency is not satisfiable

Wappler Version : 3.9.4
Operating System : Linux - Zorin 15 / Ubuntu 18.04
Server Model:
Database Type:
Hosting Type:

Expected behavior

Upgrading Wappler from a previous version works properly.

Actual behavior

Attempting to install Wappler 3.9.4 results in Wappler becoming disabled / unusable on Zorin 15.3 (which is running on Ubuntu 18.04), and breaks the Linux package manager, requiring many updates including unfortunately, requiring removal of Wappler.

More detail:
I installed from Terminal the first time, and part-way through the install it said it failed and couldn't continue (I don't recall the exact message, I've closed that terminal window).

The OS then prompted me to update a bunch of things (dependencies) because it got all out of whack (technical term) and said that the Package Installer was Broken. Hadn't seen that one before.

The only resolution was to: update the packages, and as part of that, remove Wappler.

I then used a visual package installer, to find out what was going on. Here's the result:


How to reproduce

  • Download Wappler 3.9.4 .deb package
  • Attempt the install, using Terminal
  • See the system get gummed up, and then requires you remove Wappler

Question: how do I download previous versions of Wappler? I hadn't updated in a couple months and was hoping the update would solve some glitches I've encountered with Wappler. I believe I was on 3.8.1 or so, would like to update to the latest... but if this isn't an easy fix, would prefer to update to the most recent version that doesn't require libc6 to be >=2.29 (so I can install it).

I wasn’t aware the anything has changed in our dependencies.

You might want to to install Wappler with the command line using dpkg after you download the .deb file

See also:

Thanks for the quick reply @George - that’s one step closer.

I had used dpkg -i previously, which is when I initially got the error. Based on the link you provide, I tried again using:

dpkg --force-all -i wappler_3.9.4-1_amd64.deb

Doing so let the install complete (great!), but now when I launch Wappler, it’s just a black screen:

Of course this only happens when I’m close to a release… my fault for being itchy to upgrade. I only run Wappler on one machine, so this post doesn’t seem to apply. I did try installing again, no luck.

Any ideas? Thanks for the fast responses, as always.

Here’s a bit more context, if it’s helpful - Wappler installed, but there are still unmet dependencies according to the system (only using apt-get in this case to show missing / unmet dependencies):

Maybe update to Ubuntu 20 if possible?

Not possible - Zorin 15.3 runs on 18.04 and until it updates to 16 (who knows when) and if it presumably then runs on Ubuntu 20.x, that’s when I would upgrade.

Basically, I love Zorin and I love Wappler - can’t give either of them up.

Likely, best bet is for me to find the highest version of Wappler that doesn’t have these dependencies, and install that one. Is there a way to find out what / which version that is, and get a link? I do know it’s always best to run the latest (I fully agree) to get all the bug fixing, features, so on… and soon as I can, I’ll do that. For now, I need to get Wappler back up and running, so I can get this release out.

If there’s a way for me to help Wappler out by troubleshooting those dependencies, I will… though I don’t know how to on my own.

Thanks again.

We recently switched in building Wappler under Ubuntu 20, so that is what probably changed the dependencies.

Anyway you can get the last one build on Ubuntu 18 here:


That worked - up and running on Ubuntu 18.04 / Zorin 15.3 with _3.8.2.1_amd64.deb. Thanks for the link!

Not sure how difficult it would be to continue updating on / for 18.04, and understood that the world keeps moving forward, but would be nice to have builds that run on 18.04 rather than being stuck on a dated version.

Thanks again!

1 Like

Starting from the next update of Wappler 3.9.5, we will be packaging it under the older but stable Ubuntu 18, so it will be running on all distros


That’s great! Thank you @George - very much appreciated!

It is now available in the just released Wappler 3.9.5

1 Like

This is just amazing support, responsiveness, all that - one day later, and there’s another build available that fixes my issue and a bunch more? Incredible. You have a new advocate here, for sure - I’ll tell anyone who asks (and some who don’t) why this is the best development environment around.

Thank you!!

1 Like

This topic was automatically closed after 22 hours. New replies are no longer allowed.