Unable to Connect to/Clone Private Git Repo

Unable to connect to a private Git repo on Wappler v3.6.1
We’ve got this URL from client:
it connects via SSH - private and public keys are already configured in Wappler.

have cross checked the validity of these with client.
Also, tried to connect to this repo via Sourcetree today - it worked just fine.

We had added this repo to Wappler Git many months ago (a few days just after Git was introduced in fact - and have been using it just fine until v3.5.7)
After updating to v3.6.1, suddenly, am unable to publish any more changes to the repo.
Tried to clone the repo to create a fresh project in Wappler, but getting this error:

my machine is the same, SSH is the same, upgrade to Wappler was by directly downloading and installing the exe - not via built in update (because that download is way too slow for us!).

Client is also on Wappler 3.6.1 - they can push to this repo just fine.

please help in debugging this issue. Thank you.

Hey @nshkrsh,

Maybe this will help (although I haven’t looked at it myself.)

I received an email from GitHub a couple weeks back:

Hi @mebeingken,

You recently used a password to access the repository at mebeingken/toh_app with git using git/2.0 (libgit2 0.28.0).

Basic authentication using a password to Git is deprecated and will soon no longer work. Visit https://github.blog/2020-12-15-token-authentication-requirements-for-git-operations/ for more information around suggested workarounds and removal dates.

The GitHub Team

I am 90% sure that this was triggered by a connection with Wappler, but can’t be positive. But it looks like some authentication changes at github (if that is what you are using) may be a place to investigate (although it looks like it won’t be fully disabled for another 6 months.)

Anyhow, something to add to your troubleshooting.

Thanks for your reply Ken.
We’re not using github. So that’s not applicable in this case.
Also, am able to clone the repo via sourcetree just fine. This tells me that this is something on Wappler side! But then client is able to use wappler with same repo just fine - so it’s really confusing.

It’s a self hosted private git repo.

You don’t have to specify user@

sorry that didn’t work!

removed the user@ and tried this:

got this error instantly:

Anu luck here?

Well you do have to put http:// or https:// before of course

tried - new error this time:


meanwhile, using sourcetree to pull, commit and push changes. it works well. Wappler is showing the changes as well - but unable to connect to the remote repo.

and with “http” - got back error saying ‘invalid remote URL’.

also, tried by removing the “:” after “com” in the URL, get this error:

that colon is required - sourcetree is working with the “:” in the git URL.

help here please?
with v3.7.0 - same problem persists.

We currently only allow http(s) urls, in the next update we will allow more. Then you can try with you original url or with ssl:user@domain.com:/srv/revcontrol/git/MyProject.git.

1 Like

Fixed in Wappler 3.7.1

This topic was automatically closed after 46 hours. New replies are no longer allowed.