Trouble with flows saving (or working at all)

I don’t what to raise this is a bug yet, because I think there have already been similar issues raised (and perhaps resolved). Also, I haven’t used flows for anything very serious. However, when I last used a flow, it seemed to work as expect, now they seem unusable. Perhaps something has changed since the new version 3.

I decided to use a flow as an alternative or in combination with an action file which is becoming rather complicated.

To begin with, I simply want to test for any records existing - and can’t even get this far. Whether changes are saved seems completely erratic. I created what I thought was a simple flow with a server action, a condition and a couple of alerts. I was puzzled that it didn’t work - until I realised nothing had been saved. The problem could have been that I didn’t quote the strings in the alerts (but I checked the code view and saw they had been added). I added them anyway and after several goes, what I had added was saved. At least an alert was displayed but it ignored the query result. Sometimes changing the text of the alert is saved, sometimes it isn’t. It seems quite random. I’ve tried restarting a few times (using a ‘full’ restart).

I would be grateful for any tips, or confirmation that flows should still be functioning following the v3 update.

The WorkFlow feature in Wappler v3.0.0 is working properly for me.

Yep, working for the very first time I tried.

:wink:

Tom - do not use code view unless you know the exact expression you are entering.

Just enter your texts in the visual expression builder and do not quote anything - it will be done automatically.

That’s good to know - thanks. Are you using conditions in your flows?

Yes, I am. I just followed as described in the documentation, and it works.

I’m not sure about the code for flows so would rather just use the expression builder. However, almost nothing I added would save so I had no choice. I remember flows behaved differently at one point in relation to quoting strings - that’s why I tried that.

I can’t remember what I added by hand and what I managed to do via the interface, but I now have a flow that works - a very simple condition. Even with this, if I change the text for ‘result 2’ or change the condition, it’s not saved. Obviously I can edit the code and it works:


I think something must be causing this, because the problems are very obvious so others would be having the same problems. The page concerned is quite complicated.
I’ll restart Wappler and do some more experimenting with a new page etc.

1 Like

Thanks @George.

I started a new page and created exactly the same flow. It worked without any problems at all. I pasted the code into the other file, where the flow would not work, and gave it a new id. Again, it worked fine here too - and I could edit it via the UI.

The two blocks of code are identical, except for having unique IDs, and they both function correctly. In the case of the original flow, created in that file, I cannot edit it via the UI; in the case of the new flow, created in a separate file, I can edit it.

I tried creating a new flow in this file (with the two other flows). Again, the flow was exactly the save. Having clicked ‘save’ not a single line was saved.

I’ll do some more experimenting but it would be good to know if you have any thoughts. I wonder if there could be corruption in the config.js file or is there anywhere else I should look? It might be relevant that this file was originally created quite a while ago - at least a year or two. Apart from this issue, the page works fine and there are no errors shown.

I’ve created a debug log where I create a new flow and add a single step. Nothing is saved. I’ll send it in a PM.