Server Connect in Design view gets 404 - Wappler 3.3.0

I’m having same issues with server actions since updating to v3.3.0. The server model is ASP.NET and none of the components (cards, tables etc.) from the *.aspx pages that are linked to these server actions are loading in the Wappler UI.

Failed to load resource: the server responded with a status of 404: staff_contactus.aspx?filter_staffname=:1

However, these pages are loading correctly in the web browsers. How can these pages be loaded in the Wappler UI?


I just started my work day and updated to 3.3.0 and it “broke” wappler.
I’m having the exact same problems as @guptast. My server model is PHP.
Everything was working fine yesterday.

Any advice how to fix this?

Are you on content pages or full HTML pages?

Also what are the exact errors you see in the status bar of design view? You can click there on the errors to expand them

I’m running the HTML pages in Design mode.

The error I’m getting is

Failed to load resources - status 404 - products_new.aspx

products_new.aspx is name of the Server Action on this page. The Card component linked to this server action is displaying no data.

@guptast is this a full page with the server action on it? Or is this a content page / route page / SSI?

Hi @Teodor, there are other elements such as images, texts etc. on the page that are displaying correctly. The screenshot is showing the card component only with server action linked to it.

i am asking if this is a single full html page, or is it an include/content page/ssi?

Of course you won’t see anything in the repeat region when the server action cannot be loaded …

Yes, it’s a single full html page. The Status 404 error is coming up an all the html pages where server actions are linked.

Could you try the latest Wappler 3.3.1?

Same here @George, I think it’s related with my last message: Not allowed to load local resource on content pages since Wappler 3.3.0 with NodeJS

and if you switch to your local development target is it all ok?

@George If you ask me, I tried and same issue unfortunately.

is your remote target maybe a HTTPS address?

Yes it is @George

yes that might be the problem :slight_smile:

and if you switch to local development target (which is http) then it works all fine?

Sorry for the delay, no, same problem unfortunately.

Hi @George, I’ve updated to v3.3.1 and it’s still the same issue with both local and target development targets. The remote target is running with https address.