S3 - Can't make File download / Get file work

I have an AWS S3 bucket that I can upload files to and, if public, access via a direct URL however, I can’t seem to get either the Get File action or Download File S3 API actions working. Both return null, using the same S3 connection as used for uploading the files and with bound/non-bound bucket/key values:

When output is checked, the returned data is null (the Download File one does’t have a name parameter so doesn’t have an index either)
image

I started trying to use values from a DB query before trying fixed values copied/pasted from the S3 properties in AWS - neither worked!

It is entirely possible I’m doing something wrong but I think there may be an issue with these actions. Has anyone managed to use them successfully?

(I’m using PHP for this project)

Has any one managed to get these actions to work with S3?

I‘m using Download File with S3 and PHP and everything works. Is there a reason that you use Get File and Download File?

I tried both and couldn’t get either working.

Did you have a look at the following topic?

The 2 Server Actions are for different use-cases.

Thanks Marcel.
I just had a look and I’m using the S3 File Download action:

I just get this response:
image

I have the correct bucket:


And I copy/pasted the key:

I’m not sure what else to try…

That looks like my setup. I‘m not sure but did you check CORS on the AWS side?

Is it a new project?
There was a bug in the Download File Server Action some time ago.

This isn’t a new project, but has been modified, resaved and republished today. I’m on 3.9.7 but it does look like the same issue.
@patrick could you have a look please?