Real Estate Swiper



The new responsive options work very - thanks!

Just one other thing - a useful option would be to resume auto-play if the user interacts with the swiper and then stops (eg moves the mouse away). As it is, once you have clicked on an image (eg to view the previous one), auto-play stops. Particularly in cases where there is only a single image (it seems the cube and flip options only work with one image), someone might not realise there were any more images.

(… one more other thing: I think there is a problem with the ‘fade’ effect. The images seem to pile on top of one another - or should they be exactly the same dimensions?)

Swiper - strange behaviour when filtering query dynamically

If you are using slides with images in them, then they have to be the same size. Otherwise use different effect.


Just if you’re using the fade effect? Otherwise you’ll see part of the other images behind the current one?

This reminds me of another question: what exactly does ‘Auto Height’ do? When I’ve tried it, it doesn’t seem to make the images the same height.


Swiper is not specifically image slider. It is any content slider and as such the fade effect works like that - it fades the whole slide. When one slide is above the other and the image does not fill it you see the other slide below … as your slide background is transparent. If you want to use images with different heights better use slide effect.

Auto height does not resize the content of the slides (in your case images) it adjusts the swiper height to match when slides have different heights. If you enable this option you will see the position of the paging dots changes depending on the slides height.


Thanks - that’s all very clear and makes sense.