Problem Connecting to local MAMP Database

I’m trying to set up a connection to a local MAMP Database and keep getting a “Error using this Database Connection! Can not connect to database! Check your network or server address.”

I’ve got my Server Address set to “localhost.” I’ve set my Port to both 8889, 8888 (that’s what I’ve been using on DreamWeaver), and nothing.

My Target is set up with the following info:
Remote Web Server URL: http://localhost/IMEA2
Access Type: Local Folder
Local Folder: file:///Applications/MAMP/htdocs/IMEA2

Any suggestions? I’ve tried various version of the Target info and nothing has worked so far.

Try to connect without using the port. Leave the port empty when configuring the connection in Wappler

Hi Wayne… Do you have found a solution?
I’ve the same problem from this morning.
I’ve changed with the database remote settings to upload on the hosting and now is impossible for me to return with the local db.
I’ve tried to use other projects, other local databases, uninstall/reinstall Wappler but… nothing to do, the local database connection is gone, always the error “Error using this Database Connection! Can not connect to database! Check your network or server address”.
I’m using a macOS 10.14.1 and Wappler 1.6.0.

Maybe you MAMP server is not running :slight_smile: - didn’t you got that before?

Obviously MAMP is running.
I’ve problems only with Wappler’s local connection properties but don’t worry George I’ve switched this evening to Dreamweaver :stuck_out_tongue_closed_eyes:

I have not found a solution yet. Yes MAMP is running. I have spent several hours trying all sorts of different settings, going back to the original instructions, etc. and nothing works. I can run the local version of the file in a browser and it works fine, but I can’t get the local connection to Wappler to work. Pretty frustrated. I’m loving what I see in Wappler, but without that connection it’s pretty useless.

1 Like

So if you open that address in the browser you see you site?

and what happen if you open:


What do you see in the browser

Is the file present in your local files?

and btw if you set your web server to port 8889, should the address be then:

Remote Web Server URL: http://localhost:8889/IMEA2

I’ve did do that when I changed it.

I get "connection string is required!" Am I missing a needed file?

FYI these are the errors on my local environment.
I tried to setting with Dreamweaver using your extensions but I receive the same errors; moreover, now I need to set the connection string manually with a unique voice “custom” in the dropdown “Database Type”:

I’m using macOS 10.14.1, Wappler 1.6.0 and MAMP 5.2

If you are using a MySQL database you don’t need to use ‘custom’ type, just select it from the dropdown and make sure to enter the right address, username, password and port.

Hi Teodor,
as I said before I see only “custom” type, no possibility to change it.
I tried to recreate the connection but always the same behaviour.

Is this the same site you work on Wappler?

Yes but I tried with another project built on Dreamweaver and now when I open “Database connection” see the same thing (“custom”)… also for the connection with the db on the remote hosting.
The unique things that I changed in the last days are, Wappler 1.6.0 and MAMP from 5.1.1 to 5.2.0.

In DW something seems corrupted to me, maybe reinstall server connect and database tools and try again.
But with Wappler you don’t need to use DW.

Is the error you see about database connection only for your local server?

Yes I receive the error on Wappler only for localhost connection, with the remote works good.
I used Dreamweaver only to check the error generated on Wappler.

Are you sure your local server target is properly defined - remote folder and url?
Then are you sure the connection address, user, password and port in the connection dialog are right?
Such kind of errors are usually related to wrongly configured paths/url.

Actually your database connection errors has nothing to do with your database setup.

Wappler just can’t connect to your website to upload the database stuff so tat is the whole error about.

What have you entered as remote target options and is it selected as active?

I see some weird urls like: ???

Wappler is try to connect to such domain on the internet and probably doesn’t find it - so this causes your whole troubles

Why don’t you just use localhost?