Problem building Android App

MaxOS Catalina - Wappler 2.4.5

Having to create a new App project with the Android platform, I encounter a problem that does not allow me to continue.
The System Check seems fine, but when I start the Build, I get an error.
I think it may be a problem of compatibility with Catalina, but I’m not sure and in any case I can’t solve it
Here the text resulting from the System Check and that of the error in Build
Anyone know how to fix it?
Thank you


Checking NodeJS installation and version…
NodeJS is correctly installed.

Checking GIT installation and version…
git version 2.23.0
GIT is correctly installed.

Checking Cordova installation and version…
9.0.0 (cordova-lib@9.0.1)
Cordova is correctly installed.

Checking Java SE JDK installation and version…
javac 1.8.0_201
Java SE JDK is correctly installed.

Checking Gradle installation and version…

Gradle 4.8.1

Build time: 2018-06-21 07:53:06 UTC
Revision: 0abdea078047b12df42e7750ccba34d69b516a22

Groovy: 2.4.12
Ant: Apache Ant™ version 1.9.11 compiled on March 23 2018
JVM: 1.8.0_201 (Oracle Corporation 25.201-b09)
OS: Mac OS X 10.15.3 x86_64

Gradle is correctly installed.

Checking Android Studio installation and version…
Android Studio is correctly installed.

Checking for Android SDK …
Android SDK is correctly installed.

System check successful!
If you are experiencing some build errors please make sure to check the Cordova Platform Guide for android:


Building your Cordova Project for android …
Checking Java JDK and Android SDK versions
ANDROID_SDK_ROOT=/Users/HD/Library/Android/sdk (recommended setting)
ANDROID_HOME=/Users/HD/Library/Android/sdk (DEPRECATED)
Starting a Gradle Daemon (subsequent builds will be faster)

1 actionable task: 1 executed
Subproject Path: CordovaLib
Subproject Path: app
Starting a Gradle Daemon (subsequent builds will be faster)

Task :app:preBuild UP-TO-DATE
Task :CordovaLib:preBuild UP-TO-DATE
Task :CordovaLib:preDebugBuild UP-TO-DATE
Task :CordovaLib:checkDebugManifest
Task :CordovaLib:processDebugManifest
Task :app:preDebugBuild
Task :CordovaLib:compileDebugAidl NO-SOURCE
Task :app:compileDebugAidl NO-SOURCE
Task :CordovaLib:packageDebugRenderscript NO-SOURCE
Task :app:compileDebugRenderscript
Task :app:checkDebugManifest
Task :app:generateDebugBuildConfig
Task :app:prepareLintJar
Task :app:generateDebugSources
Task :CordovaLib:compileDebugRenderscript
Task :CordovaLib:generateDebugBuildConfig
Task :CordovaLib:generateDebugResValues
Task :CordovaLib:generateDebugResources
Task :CordovaLib:packageDebugResources
Task :CordovaLib:generateDebugRFile
Task :CordovaLib:prepareLintJar
Task :CordovaLib:generateDebugSources
Task :CordovaLib:javaPreCompileDebug
Task :CordovaLib:compileDebugJavaWithJavac
Task :CordovaLib:processDebugJavaRes NO-SOURCE
Task :CordovaLib:transformClassesAndResourcesWithPrepareIntermediateJarsForDebug
Task :app:javaPreCompileDebug
Task :app:mainApkListPersistenceDebug
Task :app:generateDebugResValues
Task :app:generateDebugResources
Task :app:mergeDebugResources FAILED

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:app:mergeDebugResources’.

Specified AAPT2 executable does not exist: /Users/HD/.gradle/caches/transforms-1/files-1.1/aapt2-3.3.0-5013011-osx.jar/ed7157d69cb788867d0d16c96039074f/aapt2-3.3.0-5013011-osx/aapt2

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at

20 actionable tasks: 20 executed
/Users/HD/Studio_Wappler/TestApp/platforms/android/gradlew: Command failed with exit code 1 Error output:
FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:app:mergeDebugResources’.

Specified AAPT2 executable does not exist: /Users/HD/.gradle/caches/transforms-1/files-1.1/aapt2-3.3.0-5013011-osx.jar/ed7157d69cb788867d0d16c96039074f/aapt2-3.3.0-5013011-osx/aapt2

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at

Error building your Cordova Project for android!

I have not had any response to my request
I have tried in various ways to solve the problem, but I cannot solve it at all
I would have urgency to be able to operate in the creation of Android App
Anyone know how to proceed?

Thank you

The last error on your screenshot is about some app not being notarized by Apple.

You should switch notarization off so it runs fine. See:

I had already tried this solution but without success
I have tried again but it doesn’t work
The result is always the one reported in my previous post

Waiting to be able to solve the Android App problem, I point out that the Terminal does not work for me in the latest version of Wappler
The terminal opens but you are unable to type text

My terminal is working perfectly but i am still on Mac OS Mojave because I am too nervous to update to Catalina with all the issues I keep hearing about.

1 Like

psweb - But can you build the android?

If it can be useful, clicking on Cordova Info indicates an error:

Android platform:
ERROR: android: Command failed with exit code ENOENT

To be honest I haven’t actually tried as yet, just personally never really had the need for a real Apple App Store/Google Play Store type of App
I literally just have responsive websites that work and are pretty on mobile devices which is enough for my particular clients needs currently.
To be really honest I do more back end development of dashboards and stuff than anything else, and again they are just normal websites with functionality that are responsive on mobile devices.

So short answer is no, i haven’t gone through an App Build procedure, although i use the terminal through Wappler quite a bit.

George, maybe this is the solution:
To test the problem I used the Mac terminal, positioning myself in the <…/ platforms / android> folder of the project
So I entered the command <gradle build --scan>
The buid continues to the point that it detects the error, but asks to accept no / yes and solves the problem
Maybe Wappler should also process the build this way

FAILURE: Build failed with an exception.

  • Where:
    Build file ‘/Users/HD/Studio_Wappler/Test_App/platforms/android/app/build.gradle’ line: 20
  • What went wrong:
    A problem occurred evaluating project ‘:app’.

Failed to apply plugin [id ‘’]
Minimum supported Gradle version is 4.10.1. Current version is 4.8.1. If using the gradle wrapper, try editing the distributionUrl in /Users/HD/Studio_Wappler/Test_App/platforms/android/gradle/wrapper/ to

Nobody answers, nobody has the solution
Is it possible that there is no possibility to solve this problem?
Wappler is therefore unusable for creating Android apps
Maybe this problem is only for those who use MacOS Catalina?

Maybe this can serve?

Hi Marzio,

Actually this is not a Wappler problem but a Cordova configuration problem. Maybe you can check the Cordova github or stackoverflow and post there for solutions.

I also thought that it is a Cordova problem and maybe Catalina , and I am trying to solve it
But I was hoping there was someone as interested in the Wappler community who maybe knows more

Could be a Mac issue as building Apps on Windows works fine after installing the prerequisites required by Android (this can not be done entirely in Wappler, if anyone believes otherwise please show me how?).

The problem is certainly due to Cordova and MacOS Catalina for the failure to verify aapt2
In fact, Android Studio generates the same error when building the Cordova project
It would be necessary to find the system to force the verification but I don’t really know how to do it And I have not found anything on the web that can solve it

I’ve had days of nightmares and roundabouts getting Apps built on Windows. None of it is simple and all of it requires a lot of attention and research, trial and error. Incredibly frustrating. The salary helps with initiative to learn but doesn’t make it any less tedious. We recently started using Electron to consolidate legacy systems in to single applications across Mac, Windows, and Linux. It’s has been a revelation to us. Well worth investigating as a solution. Unfortunately Electron offers no native support for Mobile platforms such as Android at this moment. Still the Clients are happy as the end result is running on all of their primary devices. Sorry I couldn’t help further. I definitely relate to your frustrations though!

I understand and thank you
Currently with Mac for App projects I have problems only with Android, but I hope to solve.

1 Like

Hi George
I found something, which can explain the malfunction and perhaps give indications to solve it
In the first video I use Wappler to create an Android platform, and when I build I receive the two errors aapt2

In the second video I open the project in Android Studio and when I launch the build I get two aapt2 errors here, but if I perform the update that is suggested by the program, everything is ok until the emulator works

In the third video in Wappler I launch the build again, with the project modified by Android Studio, and this time it gives me different errors

Maybe we should update:

  • Android Gradle Plugin from version 3.3.0 to version 3.5.3
  • Gradle from version 4.8.1 to version 5.4.1
    But I don’t know how it can be done with Wappler

After several attempts, problem solved.

  1. On the Mac Gradle updated to version 6.0.1

Gradle 6.0.1

Build time: 2019-11-18 20:25:01 UTC
Revision: fad121066a68c4701acd362daf4287a7c309a0f5
Kotlin: 1.3.50
Groovy: 2.5.8
Ant: Apache Ant™ version 1.10.7 compiled on September 1 2019
JVM: 1.8.0_201 (Oracle Corporation 25.201-b09)
OS: Mac OS X 10.15.3 x86_64

  1. In Wappler using find / replace I have replaced throughout the project 4.10.3 with 5.4.1

Now the build works