Not possible to select parameter in flow

Wappler Version : 2.6.5
Operating System : MacOS 10.15.3

Expected behavior

It should be possible to select the parameter that is defined in the flow.

Actual behavior

The parameter is not visible to select

Try closing the flow editor, reselecting the flow node in the App Structure tree and then calling the editor again.

Not sure when this happens but it seems sometimes the flow editor looses its current selection.

Tried several times, but still not showing up.

Where is the flow placed on your page? Maybe you can show a screenshot of your app structure.


Can you verify it as a problem or am I doing something wrong? @George


Well I’m still trying to reproduce. Seems you are doing everything fine.

If not possible to select, just type it by hand:


Where parname is the name of your parameter

Yes, did that.
Just strange its only my install behaving like this.

Hi again,
I did a fresh install on my Windows machine this morning and i have the same issue.
You mean that on your system its working?

Yes, it’s working on my computer - i have no issues selecting the parameters, as you can see on the screenshots in this tutorial:

I will do the tutorial and see if i am doing something wrong.
Thank you.

I think I have isolated the issue.

If I have an include on the page its not working, if I remove the include its working.
Can you verify?

What kind of include do you have on the page and where?

The menu is in include file.

1 Like

Can confirm in 2.7.0. I have an SSI on my page and my $param isn’t available in the data picker. Even if I type in the correct value (instead of picking it), the flow still doesn’t work. I am on a Mac.

I followed Teodore’s tutorial exactly. I tried it again with a test app without an SSI on the page and it worked flawlessly.

Actually $param selection with SSI should be fully solved in Wappler.2.7.0

Please check again and make sure you are really on 2.7.0

7 posts were split to a new topic: Flow data picker errors when using SSI