Ngrok on MAMP PRO (Bad Request)

First off, this feature is amazing. Works very well with the Wappler built in server and Node.js. Very easy to set up and use. Well done!

However, I can’t get it to work using PHP and MAMP PRO as my local server.

No errors in web console or Wappler terminal.

What does the url looks like? Seems it is malformed somehow… also what is the web url for your development target?

And both urls are working? In the output between ->

You have a weird local domain, usually that is just localhost

Maybe the MAMP and it’s build-in SSL that you need to turn off.


It’s not localhost as I have about 15 sites on there. But the links work …

The Local Server link works as it should and always has. The Ngrok URL does take me to a page that says it is an unsafe site (Does that with Node project as well). But soon as you click on go to unsafe site it gets a bad request.

I think that is for a different problem that is SSH related.

So did you disable the build-in SSL in MAMP?

And make sure in your project options you have http and not https

Unfortunately if I disable SSL I can’t connect to it locally at all.

I found this on the Ngrok documentation, but I have no idea what it means or where to type in that command. :frowning:

Aha will see if we can improve that.

Yep, just confirmed that if I type in the command

ngrok http --host-header=2022Kodiaks 8888

It works as it should.

Would be nice if Wappler can do that part automatically.

Have I mentioned that I love this feature? :beers:


Still won’t work with SSL sites though :frowning:

Working on it …

I was hoping this would be fixed in today’s release. I was really looking forward to it. Hope it doesn’t get forgotten.

Sorry next time. Was too much for this update :slight_smile:

1 Like

Fixed in Wappler 5.0.0 Beta 6

1 Like

My favourite new feature! Seems to work great with MAMP Pro now. :beers:

1 Like

This topic was automatically closed after 24 hours. New replies are no longer allowed.