Nested update dialogs with 4.4.1

I have a problem with the new version 4.4.0 and also 4.4.1
If I try to save any nodeJS project file, two overlapping messages appear and Wappler crashes and I am forced to close and reopen
Did I miss something?
Schermata 2021-11-26 alle 18.01.40

I had the same issue when saving in a project for the first time since updating to 4.4.0. There are two windows - one for server connect scripts and one for bootstrap. If you say ‘No’ to the top one, then ‘Yes’ to the one underneath, then save again and you’ll have just the one so you can say ‘Yes’ to it. I had to restart a few times before realising what was happening.

I’d say it’s a bug.

1 Like

I had also tried this procedure but I was confused by the fact that it still required me to update
I have insisted a few times and now it seems solved

1 Like

It seems to be because there are multiple modals on top of each other but clicking ‘Yes’ on the top one freezes and you can’t then access the one underneath. I wonder if they have to run in order, bottom one first, which causes the issue.

Yes indeed, when multiple frameworks need to be updated, the confirmation dialogs get nested, you can still confirm them.

Will improve that in the next update.


With the latest version 4.4.2 the problem recurs if you try to save a page and this time fails to overcome the problem

Schermata 2021-12-03 alle 08.33.17

Then I managed but had to reboot 6 times

You can use the Esc button to close these nested dialogs as a workaround until this is fixed.

Ok Thank you

That’s a useful tip. Does this apply to all such dialogs in Wappler - that the Esc key will dismiss the dialog as if ‘No’ was selected?

I tend to assume that the default button is the button on the right in dialogs generally, or at least the default button should be highlighted in some way. As there’s no such indication in Wappler dialogs, I’m cautious about using Esc in case it triggers a default I don’t want.

It would be good if dialogs in Wappler were more standard in indicating a default - so you could assume that pressing Enter would trigger the default and Esc would cancel. Creating a new file is one of the few places where the buttons do indicate a default - but in this case Enter doesn’t work, and nor do the tab keys - so you have to click anyway.


I’m not sure if suggesting more consistency would be a feature request or a bug report - but it would a useful improvement in the UI.

A related problem with nested dialogs, at least in Windows, is that there is often no need for them to be nested anyway, because the same dialog appears twice, eg:


  • unless this has been fixed in 4.2.2 which I haven’t installed yet.

We will be moving all project files updates to Project Open with single confirmation, instead of on each page save.


Great - that would be a big improvement. I’ve already dismissed hundreds of these dialog boxes.

1 Like

This should be fixed in Wappler 4.4.3 - now we have a file update dialog appearing on project open.

This topic was automatically closed after 47 hours. New replies are no longer allowed.