Mobile bootstrap routing issues

There seems to be some issues when setting up new mobile projects using Bootstrap routing using 4.9.1.

I’ve attached a video showing the user experience.

Things of note:

  1. The node package dependencies is running – doesn’t seem like it should.
  2. The default view of the Project folder is /views (even though Static is highlighted). I think the contents of www be shown. Is the dynamic view even used in mobile?
  3. When creating a new content page, there are two “type” properties to select. One for layout/partial selection, the other for main page/content selection
  4. After creating the content page, an error notification hits looking for index.html.ejs in /views.

Everything just kinda goes downhill from there. :slight_smile: You can’t properly select a route, and things won’t navigate, etc.




This still happens in W5 B4 and is making it impossible (or at least very difficult) to work on Mobile projects. Could we get a fix, pretty please :pray:

Still happening in W5 B7 as well.

I particularly gave up working with mobile in Wappler, for me it never works.

I am having that same issue as well… I am trying wappler to see if it fits my mobile dev needs.

Hi Ken,
Did you have a workaround for this or did you just roll back to 4.9.0 or earlier?

Hey Ben,

I have no workaround for the creation of new projects reported, but also have not really had a need.

I’m active right now in an existing mobile project, and to change views I use the browser element:


I can’t remember how I figured out that hash bang before the route works, but it has been this way in the project for several months and works fine. I manually modify after selecting.

1 Like

Bump. @george as far as I can tell this has essentially broken any prospect of mobile app development using BS5. I’m going to have to try other products soon if it doesn’t get resolved - something I’d rather avoid!


This problem was solved a couple of updates ago - mobile projects were wrongly identified as NodeJS projects.

So it should be all fine when you create a brand new project now.

Hi @George
I don’t think this made the release…

I’m on 5.0.2 and still get the incorrect options when trying to create a page in a mobile project:

IGNORE: Ah. If you had set a mobile project up already, It still thinks it is NodeJS. If you start again from scratch it appears to work better.
Is there a way of manually fixing an existing project or do I need to start again?

Wappler still creates new mobile projects as nodeJS ones

You can manually edit the .wappler/project.json and remove the serverModel: node entry

Restart Wappler afterwards.

Just updated to 5.0.3 and still happening for new and existing projects:

Thanks @george,
This does cure it, but new mobile app projects (BS template) are being created as node server model still in 5.0.3

Are you sure about this? I tried a new mobile project and it was all fine.

I’m so sorry but once the server model line is removed, you can add pages but the routing doesn’t work (I’m previewing in browser as web package).

I have added a project with the default main page (index.html) as created by Wappler.

Added page1 and page2 (with the index.html selected as their main page) and can see them in the routing window.

The pages also have the Wappler includes lines at the top pointing to index.html and contain just a paragraph to say which page it is:

If I click the play button, it opens in browser (Chrome) as index.html but the buttons do not navigate:

As you can see from the index.html screenshot I have tried with anchor buttons and browser.goto navigation

This topic was automatically closed after 2 days. New replies are no longer allowed.