Mobile app issue running on simulator ios

Any help for this?

You can open the safari web inspector to see what is wrong. See:

is this help to debug the mobile app?

Hi George, I got your idea to find the issue, i found this please have a look at it, When i created the mobile project i have added framework 7 local 4.4.0 from the add framework option on right panel of wappler… by default it should load from the local folder where i have created the app. but the bundle not reading from the simultator into www/ .

any solution?

anyone saw this? please do support… still stuck

seems to me like you are missing include files referenced into your html page.

Could you verify all the links (and that those are relative) and the files exists - under the same www root?

Hi George thanks for replying. Please find here below the index.html code.
which exactly build and run on simulator when i got that issue.
seems like it has link to framework 7

<!DOCTYPE html>
Hello World
	<div class="panel-overlay"></div>

	<div class="view view-main">
		<div class="navbar">
			<div class="navbar-inner style2">
				<div class="left"></div>
				<div class="title sliding">Awesome App</div>
				<div class="right"></div>

		<div class="page" data-name="index">
			<div class="page-content"></div>

		<div class="toolbar">
			<div class="toolbar-inner style3">
				<a href="#" class="link">Hello</a>
				<a href="#" class="link">World</a>
<script src="cordova.js"></script>
<script type="text/javascript" src="js/index.js"></script>
<script src="Framework7/4/js/framework7.bundle.min.js"></script>
<script src="Framework7/4/js/app.js"></script>

Hi, I just created the fresh mobile app from template in wappler 2.4.0, Nothing changed, I have not touch the code or anything, just added ios platform and build and run on simulator. But same error message and nothing shows as expected. Wappler’s mobile app development totally useless…

please spend some time to check this. its annoying. could not work on clients projects.

I have taken many step to resolve this my self. even uninstalled xcode and reinstalled, nothing helped.

atleast say something that is a issue… on your side then i don’t need to try again and again… wasting my time.

------LOOOK AT THE SCREEN SHOT----------

Another issue…

Unfortunately this is not Wappler fault - Apple made Catalina to require apps to be signed first before you can run them.

You can switch it off by:

Thanks this Catalina issue is solved, But the other issue still exist!.

I just build manually run cordova command to add platform, build, run on simulator. in the same project where i actually started in wappler. I got following error messages in the terminal.

[ios-sim] An error was encountered processing the command (domain=NSPOSIXErrorDomain, code=2):

Failed to install the requested application
An application bundle was not found at the provided path.
Provide a valid path to the desired application bundle.

Anyone got it like this? any solutions? i searched online nothing helped. as i found some of them ios-sim related. but does not resolved by them.