Mailer using SMTP credentials

has anyone had any success sending emails out using Godaddy's microsoft 365 system? I have an email address with them that i am trying to use to send emails out from my website.

I setup the mailer, but i cannot get the mail to send. Continue to get a transport error. I have tried numerous ports for the outgoing mail as well with the same error

Any suggestions?

2 things to check here..
Your site has an SSL certificate? Are you on https?
Also, can you confirm your form is a Post?
I can see sender_name=%20 on the request

PS, Try to set the setup mailer under globals, and avoid adding it on the API step..
So when you choose the mailer on send mail, select it from the global

thank you for the follow-up

yes its on a https connected website and the certificates are good.

I also do have the mailer setup under Globals and that is where i am choosing it from.

I was using a form post, but it wasn't working. So right now i am just pre-filling the credientials directly in the mailer settings just to try to get it to work. I have also verified that i have SMTP authentication setup for my email address as well.

Nothing i do allows me to get it connected to the transport to send the email.

Try port 587 in SMTP settings

Also, TLS 1.2 or above is required, does your server support that? Are you using shared hosting?

or if not a fix, try port 465.

Port 25 is normally associated with non SSL connections, 587 and 465 are the common ports for SSL

yes, this site is currently using tls 1.2

Yes, for ssl, the port should be 465 as @Hyperbytes says

Can you copy the response and paste it here?

On your screenshot seems the sender name is empty.
Delete the setup mailer from the API, check the setup mailer under globals, and check if the send mail step is correctly configured

Unfortunately, that doesn't mean anything to the problem in question. Your web server may be using TLS 1.2, but the ASP code might be using a lower version to connect to the SMTP. It's the distinction between server and client. When you connect to your website, your server may support TLS 1.2 (as a server). But when your web app acts as a client to connect to another (SMTP) server, it might use an older version of TLS (as a client).

I'm not familiar with ASP, so I'm afraid I can't provide further guidance.

The error you're facing in particular mentions "transport", so it's either an incorrect port or TLS problem, or less likely a network connection problem. Basically it fails to setup a secure connection, I guess.

Does this help

no problem, i believe this is what you are looking for

here is the global settings for my mailer

here is the actual API that i am triggering on the page load. I have the sender info and the message content all added statically so i can test this.

and here is the error page that occurs with the error

As previously said REMOVE the mailer setup step from the API action, the settings are taken from globals. Also looks like 365 uses port 587

when i take the mailer setup from the API, i get this error:

If you’re using TLS, then uncheck the use SSL option in the mailer setting.

1 Like

can we see your setup in globals?

Please blank out your password or change it for screengrab!

Looking for these settings

okay, so i added back in the mailer to the API...otherwise i kept getting the send using error listed above.

i removed the SSL checkbox in the global mailer and tested

The server rejected the sender address. The server response was: 451 5.7.3 STARTTLS is required to send mail [ 2024-06-10T13:52:10.575Z 08DC888D61D76B08]\r\n

Check the port please, is it correct?

ive tried them all
25 / 465 / 587 / 993

You should NOT do this!
Settings are taken from globals, the "setup mailer" stage is a relic from pre globals introduction

okay, i can remove it, but how do i fix the SendUsing error that occurs? I am choosing the global mailer from the drop down in the SendMail selection

Have you turned on SMTP authentication within Advanced Settings on your godaddy/365 account?