Mailer using SMTP credentials

yes, i have ensured that it is turned on for this mailbox in the godaddy SMTP settings.

crazy that its not working right?

Yes, everywhere i check gives same settings

(ssl not checked)
obviously needs to authorised with username and password

Try deleting the provider and re-adding in case something has become corrupted during the many configuration changes.

use the above settings

i configured a new mailer in the Globals and used a completely different name. Then i applied it to the API function.

Still getting the SendUsing error

do you by chance have a office365 email address where you can cross check with your own email settings?

Unfortunately no, not a platform i use which leaves me struggling to make any further suggestions I'm afraid

You're still using get method? Why I see a param on your network tab item?
It says sender_name=%20
Something is wrong on how you send the mail
The error there says something like sender name " "

Can you show the form on your client side?

currently i am not using a Get method. I have all of the credientials in the actual mailer setup under the Global settings.

I also have the mail sender setup with the static email addresses and content.

Ultimately i want to use a Get method, but i want to figure out why its not working with my static settings first.

What about running directly?

here is the direct link

and still the same result

Do you have MFA or security defaults enabled? Check these directions for GoDaddy Microsoft 365 specific settings you may need to check or reconfigure -

Another relevant link direct from Microsoft a few options to use but for username/password it would be Option 1 -

I have a Microsoft tenant that I send out from but it is not GoDaddy so the configuration is a bit different. Keep in mind that SMTP basic auth will be blocked by Microsoft Sept 2025 (at least as of right now).

is there a way to control the port security type? It seems that i need to force TLS for this to work. The SSL security is not correct for this.

I was able to get the SMTP settings working from another site so i could test it and i need to select TLS

It fails with SSL

From my understanding, as long as SSL is unticked on the mailer in Wappler, it'll be TLS.

Here's a question I haven't seen asked, though: Where is your site hosted? From the screenshots, you are running the API directly from the server instead of locally. It's very possible your hosting provider has port 587 blocked. It's not uncommon for you to have to request it to be unblocked and provide them with the destination.

I'm not sure if the local server in Wappler supports ASP, but if it does, try running the API action on it so it runs locally. If it works locally, then that pretty much narrows down the issue to the ports being blocked.

Hello, Teodor already said that. If you are using TLS, you must match the correct port.

unfortunately unchecking the SSL box and keeping the same settings does not work.

also, port 587 is not blocked because i am able to use this port for other mail services like SendGrid.

On the server side, your SSL is acepting TLS 1.0. and TLS 1.1, these versions should be avoiding for security reasons, maybe the SMTP client is not negotiating the best TLS version and is taking the 1.0 instead of 1.2 as official docs says.
You could test installing a Let's Encrypt SSL certificated in domain to see if that works. these certificates start only from TLS 1.2 and above.

thank you for the follow up.
I checked the site and security under the Inspect, and it shows TLS 1.2 connection. Am i missing something else?

I can't remember the details, but years ago I was trying to do the same and there was a server-side restriction preventing the use of SMTP. I implemented MS's Graph API instead and it worked extremely well (I built a custom module for it and I could probably retrieve it, but it was PHP - I haven't read all the details of this thread, I believe you be using a different language).

This conversation is not moving forward

So I'm going to switch tactics

What's your ASP.NET version? I'm (or someone else) going to search if TLS 1.2 is supported there...

(All attempts to check the TLS version in this topic so far are invalid in the context of an SMTP client)

The TLS version of an HTTPS certificate has nothing to do with the TLS version the SMTP client attempts to use.