Mac Wappler 4 crashing when using geo location

======== TEMPLATE BUG FORM ========

Wappler Version : 4.0.0 production
Operating System : mac OS Sierra 10.12.6
Server Model:
Database Type: M$SQL
Hosting Type:

Expected behavior

shouldn’t crash

Actual behavior


How to reproduce

I don’t know how to reproduce. I had upgraded my 3.x version to 4.0.0 and started getting some random crashes. So I uninstalled and then reinstalled from scratch. Just did the drag application to the trash. Rebooted between the uninstall and manual reinstall. There might be some other folders or something I need to delete? I can’t remember where those extra folders were?

What is the procedure from here? I try to submit a bug report but it will crash before I can get it sent, and then next time I restart it says I haven’t restarted as logging to get the report?

What happens on the crash? Do you see anything?

A screenshot might help.

Also is it on specific projects? Like only Specific pages you edit? Or specific actions you do that trigger a crash?

crashes the screen, it just closes no messages no nothing. I’m diggin for the log files but it doesn’t seem to be creating them unless they are in a different folder than before

Anyway try a full installation from scratch as described in:

I"ll try a full reinstall. I knew there was another area I needed to delete other than just removing the program. I’ll let you know.

1 Like

nope no love. I try to add geo location to a page and crashes again. Did full reinstall as your post above. Still the same thing.

I can’t find any crash/debug logs, has that location changed?

Its weird, I didn’t have any problems with the beta versions…

Well there is actually not much of a different between the beat and final, so it is pretty much the same.

Check in the system console about the crashes.

no luck here at all. crashes almost immediately when I open the page with the geo location extension. I don’t think its linked to that. I’ve done manual reinstall several times now with no luck.

what system console are you talking about? within wappler or mac os?

Any chance you could resend me the 3.x version to reinstall? I’m losing work here today at this point…

So this happens on a specific page only?

no. It was happening when I was opening random pages I hadn’t opened since I had installed 4.0.0

Can you try a different project?

I closed the page that would open automatically each time that was crashing on launch. It had the geo location added to the page. It isn’t crashing now. I’m going to open a blank page and add the geo location and see if it will make it crash?

brand new page, added bootstrap 5. saved. When I add geo location, it crashes it immediatly.

Yes try to isolate when it happen exactly.
And if it is only the geo location component?

Also on what kind of page are you inserting it? Full page or content?

Also if you have another project with different server model does it work there well? Maybe it is just

ok, let me open another project and see if I can reproduce.

opened different project. did same thing. created new page, added geo location, and crash. This project is also

tested on another project, which is classic asp, geo location crashed it also

So it’s only happening when you use the geolocation component?

at this point, I think so. I’ve been trying to work on some pages that are using map and locations. So it might just be the geo location?

Found the problem!!! Is actually bug in Electron on the Mac - when using geo location!

They actually just fixed it - so we will get the latest and will be solved in the next update

1 Like

you can update my user status to ‘Bug Finder’, LOL. I am good at picking them out! Will there be an update tomorrow as its Thursday? Or will it be next Thursday?

1 Like