Installing Wappler on Arch Linux in 2022

I followed Installing wappler on Arch Linux to install Wappler on Manjaro and ran into some issues. I figured out how to solve them so here you go:

  1. Download the .deb from Wappler

  2. Install debtap either via the Aur community repository

or build it from git

  1. Run sudo debtap -u to update debtap’s own repositories

  2. Build the package debtap /path/to/wappler.deb

  3. Press Enter when you get asked for a Packager name and package license

  1. Important: Don’t skip the next step - Choose an editor when you get asked if you want to edit the .PKGINFO and .INSTALL files

  1. Search for depend = gdk-pixbuf>=2.22.0 and remove the line. gdk-pixbuf is covered in the gtk2 dependency so that’s already covered by depend = gdk-pixbuf2. It’s a debtap package conversion issue.

  1. Close and save the .PKGINFO and close the .Install file

  2. Wait until the package got generated

  1. Finally install Wappler: pacman -U path_to_your_package.pgk.tar.zst


@George it would be very convenient if you could add Wappler to the Aur user repository. Otherwise I could do that as well if you’re okay with that.

No worries if that’s a no go. It would make it a 2 click installation though.

Well you can send me a private message with instructions so I can check it and try to automate it.

As we already have 4 different builds weekly and if we have to do more, I will rather do them automatically.

And would also like to cover other different distribution binary installers like red hat rpm

1 Like

I’ll write a bash script for you this week and send it to you with instructions :slight_smile:

1 Like

@George Any chance you can include a build for Fedora ?

I struggled a bit to install Wappler on it, but I could do it by following these instructions:

So you did successfully convert the Wappler deb file to rpm with this instructions and it installs all fine now?

Correct! So the only issue after using Alien were file conflicts.
And those instructions indeed solved them :slight_smile:

1 Like

I will see if we can integrate that in our build process.

1 Like

Is everything ok with the tray icon of Wappler on Fedora? Seems they have made some changes in there.

I’ve packaged further an rpm installer of the latest version, so you might want to check it out if everything is ok with it, get it from:

Btw if you experience tray icons missing problems in the latest Fedora 35+ try this:

Thanks, appreciate it!

On holiday right now - but hopefully I’ll have some time to try it soon!


I uninstalled the old package, installed yours and it amazingly was finished in about 5 seconds!!

Upgrading using this button didn’t work, it gives me a ‘Failed to install file: not supported’ error.
So I think you’re good to go, and build this package for each release automatically :smiley:

1 Like

@George Thanks for the RPM build.

2 Notes:

  1. The update button doesn’t work (not sure if it’s supposed to work?)

  2. When installing the new package, it simply says ‘open’. However I haven’t updated yet.
    This might be because I’m new to linux but I’m expecting an ‘update’ button.
    Should I always uninstall and install again manually?

    Answered this question by myself, there’s a rpm --upgrade command :smiley: which worked well

Actually I was wondering the same. Seems the Software update gui in Fedora doesn’t provide upgrade option only delete and open.

We could run rpm --upgrade but I think it requires sudo.

How did you ran it?

Yes with sudo

Perhaps you can do it the same way as with Docker?
When I start Wappler, and Wappler tries to start Docker. It asks for my sudo password anyway:

1 Like


Just to confirm, if you can automate this, it should work fine. This is all I do to update now:

  1. Download the new rpm
  2. Shut down current Wappler
  3. Run sudo rpm -U filename.rpm