Include path problem


Help. I’m not sure what happened but my navbar now disappears on my main page

Add a hyperlink to an image

Can you provide a link to the page giving you problems? Or is it just going away in Design View? I find sometimes when I make changes I have to either fresh the view or in some cases close and open the file again.



Looking at your source code there is no Navbar on the page. Are you sure you didn’t inadvertently delete it in your design view. Does it show up in your Design View?


shows up in design view. when I hit save it disappears


Then when you re-open the file it is back? This is indeed a strange behaviour. Is your Navbar selected when you save?



here it is, I clicked off of it on the menu and it still disappears. Its a php include on line 42


crap, this is happening on any page i save rendering my site useless with no nav


I have a feeling it has to do with the include file. Have you made any changes to it? The include file itself seems to be the common denominator. Just out of curiosity can you create another include file with just some simple text or something on it and place it in the same place as your navbar include?


I did change some stuff but I restored the old include to keep my site running

the other page that lost the menu after save gives this error

SyntaxError: JSON.parse: unexpected character at line 2 column 1 of the JSON data


Ok, I think I know what the problem is. It may be related to the new auto linking in this version. Did you update Wappler today?

Looks like you have some links that are relative and some are site root.


yes i updated

it used to be I had to ad …/ etc


I have a suspicion that is where your problem is. Did you add the …/ to your include file?


within the file itself?


i think i added it in each page depending on the depth of the page in file structure
withing the file itself there is a link that has …/


Try going into your site preferences and change the Links Relative to setting to the opposite of what you have.

I have a feeing that if you look at the code on your index page and a page that is working, your . actual include line will be different.


Or remove the include altogether and re-add it that should work as well.


why is the code view showing up grey?

I’ve tried replacing it already


Hmmm, not sure why it would be greyed out. If you open a page that works (don’t save it) is it greyed out on those too? Is it the same code?


Ok, I logged onto my home pc and restored both files then pushed them up with my un updated version of wappler in case it was the update. I have to leave but something seems screwy