Include path problem

fixed-in-next-update

#21

I have a feeling it is the new feature in today’s update.


#22

by the way, the only files i restored were the ones that were not showing the nav bar. Ironically I was working on the nav bar today if that helps.

Hopefully you guys can explain what the new feature is doing so I can deal with it. right now i’m not changing anything on any of my sites. If i do i’ll use the home machine


#23

I’m sure @teodor will confirm my suspicions in the morning. I am sure it has something to do with the path to the include being overwritten. Good luck.


#24

Hello @rokit

  • What are your links set to in your project settings?
  • How did you add these includes - i.e. using our UI or just copy/pasted some links between the pages?

#25

Got the same issue, existing website completely broken due to include links not working correctly. THios is pretty serious, customer furious, has just pumped a fortune into google ads to promote a broken site


#26

Brian,
Can you explain what exactly is “broken” as without any details we cannot really understand what the issue is?


#27

Every link to an include is generating an error. I have tried remaking them but not a fix.
Virtually every page has a menu and a footer via a php SSI and i am getting this everywhere

error line is
{“code”:0,“file”:"/home/sites/7b/1/114fdca835/public_html/users/showroom.php",“line”:71,“message”:“include(/usermenu.php): failed to open stream: No such file or directory”,“trace”:"#0 /home/sites/7b/1/114fdca835/public_html/users/showroom.php(71): exception_error_handler(2, ‘include(/userme…’, ‘/home/sites/7b/…’, 71, Array)\n#1 /home/sites/7b/1/114fdca835/public_html/users/showroom.php(71): include()\n#2 {main}"}


#28

The code view of this line is

<?php include '/usermenu.php';?>

The file in in the root and this link has been working for 5 months!


#29

Why do you have your projects settings to links Relative to Site root and not document?


#30

That’s the way i normally do it, i find is easier, you suggesting i change to document may fix this?


#31

well that is the option for, we just finally got it working :slight_smile:

So if you want Site root relative links - full links starting from the site root, choose that and if you want relative links to the document, well choose Relative to document …


#32

I always have it set to Site Root

What do i need to fix this, the whole site is broken due to SSI link errors


#33

actually we don’t touch SSI include links on save … so what is wrong with the link?


#34

aren’t you just missing a file on your server?


#35

This is correct path shown in app connect (until i save then it changes to a wrong path)

image

On save the link is re-written in the code to

image

The …/ is removed, so link is broken

I cant manually correct his as re-write undoes the changes


#36

Brian - the link is not the problem …

in usermenu.php - you have another include link that does not exists to users/showroom.php


#37

I know that with relative to site root this should be ok but the link seems to break, i really dont know what is happening

The menu is definately there (been there 5 months). I can call it directly with https://bookastudentroom.com/usermenu.php


#38

Brian you ware not reading what I’m saying … it is not a problem with usermenu.php but another file …

just as the error says:


#39

Could it be something quite different? I get security problems if I try to access the link above. I tried with Chrome and Firefox. Could there be a problem with the SSL certificate?


#40

I am totally confused george, an entire section of the website is just showing code output and an error linked to the menu include, that’s about 20 pages all with the same error

I remove the SSI links and the pages work. Are you saying it is not related to the SSIs?