Htaccess not copied to target

Also got stuck with it. I’m on mac. Icons doesn’t show, so I can not work basically (
I tried restart Wappler, and also restart Mac. Doesn’t help. Any ideas how to fix?

Also there is another problem which I didn’t report yet. .htaccess file with routes doesnt copy to target on local machine. Something with write permisson for hidden files I assume. Didn’t found a way to fix it.

You just need to restart Wappler and it will be fine.

Are you sure you hit the upload button?

Hi, Teodor.

  1. Doesn’t help. Tried several times.
    Now re-installed Wappler 2.2.6 still there.

  2. Of course I use this button. In the log it says successfully transfered, but it’s not. I use MAMP as a local web server.

And this only happens on your local MAMP server?
Maybe you need to check your permissions then…

Yes, only on MAMP. Digitalocean remote target is OK.

It was working fine up to 2.2.6. Don’t have a clue which permissions to check? Can you please advise?

Thanks. Will wait for the fix.

As for MAMP and .htaccess file, I see in the terminal that it’s copied successfully, but in reality it’s not. If it was permissions trouble, I assume there would be a error in the terminal.

@alexey could you please try to report different problems in separate posts?
I have splitted them now.

Also what is your exact Mac version - as I see there is something wrong with the output as well.

Sorry, George. Agree, should do everything systematic. Reported a bug separately.

Ups, misunderstood you and created duplicate. Teodor already closed.

About mac versions:
Operating System : MACOS Mojave, 10.14.6 (18G95)
I use MAMP ver 5.4 as a local target.

Checked again.
Both on 2.2.5 and 2.2.6 same behaviour.

Please restart Wappler with logging, reproduce the problem and attach the debug log. See:

Hi, @George. Debug log attached. (192.2 KB)

Also pictures of my source directory contents, and MAMP target directory.

Btw, besides .htaccess there is also a .wappler hidden folder. Should this folder also be copied to Target?