Heroku first site can't login

Wappler Version : 3.7.3
Operating System : mac
Server Model: node
Database Type: none
Hosting Type: heroku

Expected behavior

I should be able to provide credentials for logging into Heroku or be prompted for the system check.

Actual behavior

Both modals open up, and what remains is the login – Every time I click on username, the modal closes and reopens.

How to reproduce

Debug and video attached.

After restarting Wappler, the system check is properly presented, and the Heroku tools is installed. Everything works after that.

It looks like the login and system check are colliding so anybody that has not done a heroku project will likely hit this problem.

Screen Recording 2021-02-03 at 1.58.13 PM.mov.zip (14.8 MB)

chrome_debug.log.zip (4.4 KB)

Maybe try to update the heroku cli tools to the latest

I already have it working, I’m trying to help you make the product better with a bug report. :slight_smile:

1 Like

Seems this happens if you switch different Heroku accounts. We assumed that only one account is used.

Try to login before going to the Git Manager panel:


Or if the login popups, just press cancel and then login via the toolbar.

Does that work for you?

The problem original occured on my very first attempt to use Heroku. I had never entered any credentials, and even now, have only entered the same user each time.

I think if you remove the authorization for heroku and attempt to create a project, this problem will occur again.

but is it ok if you login from the toolbar?

Yes, if you are on a project with heroku hosting, then you can click on the login and that login works fine. The problem is just that when creating a new project, you don’t have the option to login first, because those icons will no be visible.

Well usually if you are not logged in another prompt should appear on project open, that asks you to login first.


weird that this one doesn’t appear to you. Maybe you were already logged in for a different Wappler Heroku project.

Take a look at the original movie I posted (sorry, I zipped it first by mistake.)

It very briefly shows this:

Improved the Git Manager not so it detects the special Heroku logins and prompts you for one if you haven’t logged in yet.

So this will be solved in the next update

1 Like

This has been fixed in Wappler 3.7.7

This topic was automatically closed after 44 hours. New replies are no longer allowed.